summaryrefslogtreecommitdiff
path: root/app-vim/vim-latex
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
commitf78108598211053d41752a83e0345441bb9014ae (patch)
treedd2fc7ae0a1aea7bda4942ab0c453d1e55284b37 /app-vim/vim-latex
parentdc45b83b28fb83e9659492066e347b8dc60bc9e3 (diff)
gentoo resync : 11.02.2018
Diffstat (limited to 'app-vim/vim-latex')
-rw-r--r--app-vim/vim-latex/Manifest2
-rw-r--r--app-vim/vim-latex/vim-latex-1.10.0.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/app-vim/vim-latex/Manifest b/app-vim/vim-latex/Manifest
index 87db4729dba2..1013ac557027 100644
--- a/app-vim/vim-latex/Manifest
+++ b/app-vim/vim-latex/Manifest
@@ -1,5 +1,7 @@
+DIST vim-latex-1.10.0.tar.gz 260820 BLAKE2B 2314ad5ded3bea51def3172e8f2b7a7483839b58804f9d8c1cc1c8f1139c1da731f91525691d47dba57d07a7db85c371e87c5ce0d3d22a004a9402df7e7cad3a SHA512 1d22b675c124e402a280dcc3a675b49a92fb9f4d42efdda0ea97be26379cd6c023589a35e165f4231524d853380e22411901bfbcc98f171c938ba800821a1213
DIST vim-latex-1.8.23-20141116.812-gitd0f31c9.tar.gz 288376 BLAKE2B e9853e3c86764147401f9ad6909f216864f97b9b35ca84839c7047555a52ad51d9488930a820a275b27331cc8a52360c1ce0550fe93d2d6efce8873ba1214572 SHA512 18444b7aef9ca1d7288e2616c0329274172afa3f932096fddc5e40888f65c8cacae2454ab316c5699395268aa88af13b32f3ae6e36058e27e4e48e6d6591b762
DIST vim-latex-1.9.0.tar.gz 289271 BLAKE2B 1372fb590d9f3726de51439c4110911c8404dedbf17a0d8d651fcea34fba3d1622440a90b5974a1d45eafec5d079c8b84fb0665b0203bbf5df75a10caa0161df SHA512 4cce21683af74a5a1034e5ecc0f6268b5065324908671d40b4d6b60ac880890df1e9c3d6c16fa57dd1edc33766ded374fd43473699a974ba83e4aeac42030e63
+EBUILD vim-latex-1.10.0.ebuild 1562 BLAKE2B 4fff83431f075a939b1d078ae3fb7cbc8923794688e79f8c94fe144a8307cac97b31f9dc10ee44e2ad851c06bb2eb4e28fb05d732f884212abf85798d998babd SHA512 d8c676ba9b77138f9d1b5ead7e162c1d1f3498f737393be89c51981dc514c038cee3a0b6c8492d210825360ece301446c8c81dd96445f1f60651cb4fdce21cd2
EBUILD vim-latex-1.8.23.20141116.ebuild 1798 BLAKE2B 4b7f902259cd009e679cc9fc6630e6c7e3930f336b8f986658fd05c94a68e23651c24fa7e43ce242a1df71bc8f69a9291ea981170a18c05eb6ad5fc031bcc753 SHA512 aeffb7b9e604b1941a471bd51fb13aa8c2de410c549b5a07724242adb87158064e23312a4add2c82cdc07da34350fbdd537bafff65b555c97d95cb16bac3c972
EBUILD vim-latex-1.9.0.ebuild 1562 BLAKE2B edf753de348d5440512d9684ae877eb163931aae600e3dc240b84bef3acccdf4adbe481f15786fee3148780bca98ac313007414ff8be30707693d384cc327bc8 SHA512 cfb7cccf342788042957425fdf5c1fc1a67836b4cab5ee26513a1c04a8ebf545d5fa4f583c84d934d71c7229adcaf373d8c256c1c871c4519bd7c671ed6012b6
MISC metadata.xml 397 BLAKE2B 836fedd8d82a8d856303e7a962cf96205b9a9a31cb50cc31bf93589fefb96769f594951fc9f3966a7dccf6196e35ef524feb8e363662da3ae53019099a97ce5e SHA512 739228ae8405270009e652df3cce873daa3c7548aeaa0a058a8202e1ecaa844adf11564a54d73082d5b0b191a2d3c84560460c65b960701e22f6cc497fc6eecb
diff --git a/app-vim/vim-latex/vim-latex-1.10.0.ebuild b/app-vim/vim-latex/vim-latex-1.10.0.ebuild
new file mode 100644
index 000000000000..1fe1ad06f6f4
--- /dev/null
+++ b/app-vim/vim-latex/vim-latex-1.10.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit vim-plugin python-single-r1
+
+DESCRIPTION="A comprehensive set of tools to view, edit and compile LaTeX documents"
+HOMEPAGE="http://vim-latex.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="vim"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ || (
+ app-editors/vim[python,${PYTHON_USEDEP}]
+ app-editors/gvim[python,${PYTHON_USEDEP}]
+ )
+ virtual/latex-base
+ !app-vim/vimtex"
+
+VIM_PLUGIN_HELPFILES="latex-suite.txt latex-suite-quickstart.txt latexhelp.txt imaps.txt"
+
+src_compile() { :; }
+
+src_install() {
+ # remove unused metadata
+ rm vim-latex.metainfo.xml || die
+
+ # don't mess up vim's doc dir with random files
+ mv doc mydoc || die
+ mkdir doc || die
+ mv mydoc/*.txt doc/ || die
+ rm -rf mydoc || die
+
+ # don't install buggy tags scripts, use ctags instead
+ rm latextags ltags || die
+
+ vim-plugin_src_install
+
+ # use executable permissions (bug #352403)
+ fperms a+x /usr/share/vim/vimfiles/ftplugin/latex-suite/outline.py
+
+ python_fix_shebang "${ED}"
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ echo
+ elog "To use the vim-latex plugin add:"
+ elog " filetype plugin on"
+ elog ' set grepprg=grep\ -nH\ $*'
+ elog " let g:tex_flavor='latex'"
+ elog "to your ~/.vimrc-file"
+ echo
+ fi
+}