summaryrefslogtreecommitdiff
path: root/app-vim/vim-latex
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/vim-latex
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/vim-latex')
-rw-r--r--app-vim/vim-latex/Manifest3
-rw-r--r--app-vim/vim-latex/metadata.xml11
-rw-r--r--app-vim/vim-latex/vim-latex-1.10.0.ebuild64
3 files changed, 78 insertions, 0 deletions
diff --git a/app-vim/vim-latex/Manifest b/app-vim/vim-latex/Manifest
new file mode 100644
index 000000000000..f58b85f20d87
--- /dev/null
+++ b/app-vim/vim-latex/Manifest
@@ -0,0 +1,3 @@
+DIST vim-latex-1.10.0.tar.gz 260820 BLAKE2B 2314ad5ded3bea51def3172e8f2b7a7483839b58804f9d8c1cc1c8f1139c1da731f91525691d47dba57d07a7db85c371e87c5ce0d3d22a004a9402df7e7cad3a SHA512 1d22b675c124e402a280dcc3a675b49a92fb9f4d42efdda0ea97be26379cd6c023589a35e165f4231524d853380e22411901bfbcc98f171c938ba800821a1213
+EBUILD vim-latex-1.10.0.ebuild 1572 BLAKE2B b3ed9e89f7149ccd79c4db2c5a90af6b44609c489c0008f6176c6f51c0145c4f35fd7a51e9e6c780596ec3e42a88269e12569ef850f4e255c4ed436eb12f8d7e SHA512 748534b202c3a2cb725ae30fcdcf86f3cffc1102b3e5af2c4bb3899c5a23217d52e32cd9f7b38f06b797eade0bd92af6fe8bffa2e1a6033f64510b0efab0a966
+MISC metadata.xml 328 BLAKE2B bcf4c9979e43da6c141669c218e852e7a0c062d900c35790709e393f6cabc56f646f7a84e8057d9dbafa0a73e5786135a7cfe3ef825af867500bcd502f03a61f SHA512 e14b88742b6d8143cb578ddac61dbc0ac5e84c90659e8d9b5c40882ebdf35dc001b1ffae26eb90617434b2c8a898055c838738bf7cf18a45cd2a2ce66a30bdce
diff --git a/app-vim/vim-latex/metadata.xml b/app-vim/vim-latex/metadata.xml
new file mode 100644
index 000000000000..20ffb74c87d2
--- /dev/null
+++ b/app-vim/vim-latex/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">vim-latex</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/vim-latex/vim-latex-1.10.0.ebuild b/app-vim/vim-latex/vim-latex-1.10.0.ebuild
new file mode 100644
index 000000000000..beb4e7760e64
--- /dev/null
+++ b/app-vim/vim-latex/vim-latex-1.10.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit vim-plugin python-single-r1
+
+DESCRIPTION="A comprehensive set of tools to view, edit and compile LaTeX documents"
+HOMEPAGE="http://vim-latex.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="vim"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ || (
+ app-editors/vim[python,${PYTHON_USEDEP}]
+ app-editors/gvim[python,${PYTHON_USEDEP}]
+ )
+ virtual/latex-base
+ !app-vim/vimtex"
+
+VIM_PLUGIN_HELPFILES="latex-suite.txt latex-suite-quickstart.txt latexhelp.txt imaps.txt"
+
+src_compile() { :; }
+
+src_install() {
+ # remove unused metadata
+ rm vim-latex.metainfo.xml || die
+
+ # don't mess up vim's doc dir with random files
+ mv doc mydoc || die
+ mkdir doc || die
+ mv mydoc/*.txt doc/ || die
+ rm -rf mydoc || die
+
+ # don't install buggy tags scripts, use ctags instead
+ rm latextags ltags || die
+
+ vim-plugin_src_install
+
+ # use executable permissions (bug #352403)
+ fperms a+x /usr/share/vim/vimfiles/ftplugin/latex-suite/outline.py
+
+ python_fix_shebang "${ED}"
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ echo
+ elog "To use the vim-latex plugin add:"
+ elog " filetype plugin on"
+ elog ' set grepprg=grep\ -nH\ $*'
+ elog " let g:tex_flavor='latex'"
+ elog "to your ~/.vimrc-file"
+ echo
+ fi
+}