summaryrefslogtreecommitdiff
path: root/app-vim/vim-hoogle
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-vim/vim-hoogle
reinit the tree, so we can have metadata
Diffstat (limited to 'app-vim/vim-hoogle')
-rw-r--r--app-vim/vim-hoogle/Manifest3
-rw-r--r--app-vim/vim-hoogle/metadata.xml11
-rw-r--r--app-vim/vim-hoogle/vim-hoogle-1.3.ebuild16
3 files changed, 30 insertions, 0 deletions
diff --git a/app-vim/vim-hoogle/Manifest b/app-vim/vim-hoogle/Manifest
new file mode 100644
index 000000000000..de21df92039b
--- /dev/null
+++ b/app-vim/vim-hoogle/Manifest
@@ -0,0 +1,3 @@
+DIST vim-hoogle-1.3.tar.gz 3337 SHA256 e1a9b3d9f0741cec04d59cc8ce7806a0e801236e4f25b06d508270bd3b01d2a4 SHA512 ea0d2b723e913836dbff5947e7de4fb5dda19ab1d3bd51cd315b28499f1b6c771b037b16eec6a88862d27f675a9ddac11eb5d8d5a5b3ee3e2eeb7620ed4d565a WHIRLPOOL 641109deddbde97f4d31e3542256e392f72845239f235710b877bad06efd2af9ec9e3718ba7797f01bd8b8c461bef7491a195a3695e773c0a1b9744a52fae1d4
+EBUILD vim-hoogle-1.3.ebuild 478 SHA256 c8a3ee1b4ba315ade181704b0824794722b894a954ef61ee3e8a2edf8405496c SHA512 b62c15abf6b0b4c67aa6ede9ee4f9021ea97ef6c97a40c2a44fa4b5cd679b851c2ad473ddd9b2912e2c14e17a8d3514a7fd775679908383a5b2ba300a86e0f15 WHIRLPOOL 66d715679a3dbf842d631639461db5441e35c89ac70eb83b62744928490a140e9f77dd54b4687fc90ba673f9c988ceb473db03a58d31ec347dce8f58cd14583b
+MISC metadata.xml 333 SHA256 ae8c58283a99969e624e1fd00b1732df5df570bd09f9eb8f5728d7a7bc64c26e SHA512 b24d12456a6fed3864c3159aa935ad04875970f1995b4b6d21fdc3e04dee04c20561a489494c0cc8d8f1d59b880a8bb6156ecd2966ca196b17f9ec0746c78def WHIRLPOOL a5117ed8ac6e17fd906a084cfc75eb38b85ca415bda21c86a89924a68d6f8e26a09954c34ca7099be85bcf6581756b40971c97904e58d1a923c3eb9b27670092
diff --git a/app-vim/vim-hoogle/metadata.xml b/app-vim/vim-hoogle/metadata.xml
new file mode 100644
index 000000000000..ee47616d507b
--- /dev/null
+++ b/app-vim/vim-hoogle/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Twinside/vim-hoogle</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/vim-hoogle/vim-hoogle-1.3.ebuild b/app-vim/vim-hoogle/vim-hoogle-1.3.ebuild
new file mode 100644
index 000000000000..1dee86affdcf
--- /dev/null
+++ b/app-vim/vim-hoogle/vim-hoogle-1.3.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+MASTER_COMMIT_HASH="31823f830843385f53a3da7a5bfaf678494383c4"
+
+DESCRIPTION="vim plugin: use hoogle within vim"
+HOMEPAGE="https://github.com/Twinside/vim-hoogle"
+SRC_URI="https://github.com/Twinside/${PN}/archive/${MASTER_COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
+LICENSE="vim.org"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${PN}-${MASTER_COMMIT_HASH}"