summaryrefslogtreecommitdiff
path: root/app-vim/vcscommand
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-vim/vcscommand
reinit the tree, so we can have metadata
Diffstat (limited to 'app-vim/vcscommand')
-rw-r--r--app-vim/vcscommand/Manifest5
-rw-r--r--app-vim/vcscommand/metadata.xml13
-rw-r--r--app-vim/vcscommand/vcscommand-1.99.47.ebuild15
3 files changed, 33 insertions, 0 deletions
diff --git a/app-vim/vcscommand/Manifest b/app-vim/vcscommand/Manifest
new file mode 100644
index 000000000000..042bf0e10f28
--- /dev/null
+++ b/app-vim/vcscommand/Manifest
@@ -0,0 +1,5 @@
+DIST vcscommand-1.99.47.tar.bz2 27281 SHA256 1e219f3e941e49086fb5083a1493c9563cffd004e8bae8a7f6ac65596adf3f56 SHA512 df9180cc3a87dc5fab52d149c1f87993822658edabd77965756fa8ba05ef6f1c5a4f336b54d0b18e3c2bba8f53324ca60526258953a85ce170ab065b5f2e11c7 WHIRLPOOL 9c056921e8757b234ce71a840a7fcebb507dfe7813f2034bdb360ac60038cbfc01fc333353ec8b24b8142236271fa1295d53d7c5650046cbbb61f5bc6a80d478
+EBUILD vcscommand-1.99.47.ebuild 437 SHA256 2d4154ae41e4a63a21ebe596ea03d42f9a6bc5ab39257125395dba1058b27919 SHA512 d7e274397beb1eeac8a8aa5efaee85848258a4897718d78f6b698f5642cfe97f3bdb9045707c7430182922c5bf82b9c92e75cc5f86f04d727a6c703b57ad21c4 WHIRLPOOL 6110ddc51bfde5abe9f113a14cd01885bd4edcc2d0623f8e136fd295860393edce5d37252d4c2c2ddd2afcb811cf90882129ee7ac7e785f974978b357f6c428f
+MISC ChangeLog 2439 SHA256 8182fe2de1f9d1d17a04fbe09efcf125c18e40d6fb0e674b0f6859eb3d2ece29 SHA512 397eae593780069813142d59081527e56a2652275543ed15f936ae3733dae604017e39edfbdfec4ba0c6bfdb6485ed619b08f0cca90e608a73e9873839af6e2a WHIRLPOOL 75cb6bf9a5d938b5d3d486ba59b60bb6a8b7b236848b03499890d5f19129f489076aed40157f6c65412d66c85d65943db73076e24f58ba3c471a655bb5455f07
+MISC ChangeLog-2015 4769 SHA256 9ce1592b4ad23d942d82c740be89588abb18978e9963cbb09cb3c02eded84b6c SHA512 140ccc7915e6111568ce1552839d1073507c07b8cc7278d72472a816a1b940ae66ca4b99e41ebe5e72845e56e4e8e644b5618e8cc524b47c16cfd3f15afe9ef7 WHIRLPOOL 30f413a7436cf31bf0d740ba6502bf1683feadcdba6476ffebd06c712c47bd3f85fcb13eccdb5f71a791654e047308bd7bea46e8d688a761e9b6509bdd6b933c
+MISC metadata.xml 472 SHA256 291e9a251359d88606bf23476c76bc4b364c527bc1cdbc4543eb43c12bc03d46 SHA512 1fe14c8bf9e490646436b8ebd10898f79ea5614a894382397b07dcded1d37f2b8534858c38db7cb2fc859d839a1973f685e96cb9340b2b254273e9e627e3c970 WHIRLPOOL a95edea03fdba5c1859726e4634df08e2dfa4137573e47d0fbfc506de388d44038295b599fa7446e782ed0d4b4b86b4e0e51d7d4d4a11762a6d9e1b12ff6e14e
diff --git a/app-vim/vcscommand/metadata.xml b/app-vim/vcscommand/metadata.xml
new file mode 100644
index 000000000000..8dacacbba2cd
--- /dev/null
+++ b/app-vim/vcscommand/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+</maintainer>
+<longdescription lang="en">
+ VIM 7 plugin useful for manipulating files controlled by CVS, SVN, SVK, git,
+ bzr, and hg within VIM, including committing changes and performing diffs
+ using the vimdiff system.
+</longdescription>
+</pkgmetadata>
diff --git a/app-vim/vcscommand/vcscommand-1.99.47.ebuild b/app-vim/vcscommand/vcscommand-1.99.47.ebuild
new file mode 100644
index 000000000000..ca4c1e3fface
--- /dev/null
+++ b/app-vim/vcscommand/vcscommand-1.99.47.ebuild
@@ -0,0 +1,15 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: CVS/SVN/SVK/git/bzr/hg integration plugin"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=90"
+LICENSE="MIT"
+KEYWORDS="amd64 ~hppa ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+
+RDEPEND="!app-vim/cvscommand"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"