summaryrefslogtreecommitdiff
path: root/app-vim/unite
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/unite
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/unite')
-rw-r--r--app-vim/unite/Manifest3
-rw-r--r--app-vim/unite/metadata.xml17
-rw-r--r--app-vim/unite/unite-4.0-r1.ebuild15
3 files changed, 35 insertions, 0 deletions
diff --git a/app-vim/unite/Manifest b/app-vim/unite/Manifest
new file mode 100644
index 000000000000..555328545911
--- /dev/null
+++ b/app-vim/unite/Manifest
@@ -0,0 +1,3 @@
+DIST unite-4.0.tar.bz2 80472 BLAKE2B 8150ac276f4e64458f3ab08dc48ddb4167a36162bdb291e59fb376e2a061b80f1760a195667a2794a7657f32367714dd60874cfcd2c363366dcbfde07a3224f0 SHA512 e554e48d740b0ce6406d8512a0c769e25f78b763d267bbbf8228197835b724154f33452571c771fede1415a9b3108deb096e3bc90291a95e8a3b00d216287928
+EBUILD unite-4.0-r1.ebuild 348 BLAKE2B 4a0f045c6287bd886920c8c77636e3d5aabe44812ce57f83b32b45c10791692d1e1af7f7aec5f474826f89879c4c269646bc2ad233d44d364119987bb2ed0da2 SHA512 42406dc5ce47d57b57b9cea11e2bf3634de53387b6bb491ddcf98cb8ec9b10598c9065bca13e69ef163a3cb4953d42a27690f728902a2ccb1cfc60981a601861
+MISC metadata.xml 669 BLAKE2B ef1526852b482b0429416f74a8a1bbe44e000ad792ca0a7cafbd1989da9c480f27f7590bbd76f06de18dc932e6979d912b458c6b181aa5201b96c4024ef726c3 SHA512 9a1b6ee71975656291278d75923247438be875af17abf1395a08ac3e9c8ee10b72830f0380117fad38214257ab01fbec35e45b0ce9ae7791a96a1f10cf065426
diff --git a/app-vim/unite/metadata.xml b/app-vim/unite/metadata.xml
new file mode 100644
index 000000000000..393dd84dde7c
--- /dev/null
+++ b/app-vim/unite/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Unite searches and displays information from arbitrary sources like files,
+ buffers, recently used files or registers. You can run one of defined action
+ on a target displayed.
+
+ The differences between unite and similar plugins like fuzzyfinder or ku are
+ that unite doesn't use the built-in completion interface of Vim, and integrates
+ sources at the same time.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-vim/unite/unite-4.0-r1.ebuild b/app-vim/unite/unite-4.0-r1.ebuild
new file mode 100644
index 000000000000..8c036e471faa
--- /dev/null
+++ b/app-vim/unite/unite-4.0-r1.ebuild
@@ -0,0 +1,15 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: unite all sources"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=3396"
+LICENSE="MIT"
+KEYWORDS="amd64 x86"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="!app-vim/neocomplcache"