summaryrefslogtreecommitdiff
path: root/app-vim/udev-syntax
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/udev-syntax
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/udev-syntax')
-rw-r--r--app-vim/udev-syntax/Manifest4
-rw-r--r--app-vim/udev-syntax/files/udev-syntax-20051016-ftdetect.patch6
-rw-r--r--app-vim/udev-syntax/metadata.xml11
-rw-r--r--app-vim/udev-syntax/udev-syntax-20051016-r2.ebuild18
4 files changed, 39 insertions, 0 deletions
diff --git a/app-vim/udev-syntax/Manifest b/app-vim/udev-syntax/Manifest
new file mode 100644
index 000000000000..975d0a73483b
--- /dev/null
+++ b/app-vim/udev-syntax/Manifest
@@ -0,0 +1,4 @@
+AUX udev-syntax-20051016-ftdetect.patch 371 BLAKE2B aeeba09718dd8292ff9a7c8092597eacf422bd49c703e526158c1130e436fe6c342e08cd4c974e762ba8b1dba45166437831806e7c889d5656b7ab6d78b382ef SHA512 41369f811f4ce28f182ac61c3113f38248aee839a9d52ee6ba83a48d3689873b9afe69bc938d2c40c06d2fa94b72c2e904a4b338dc24d6131492eb05192395cd
+DIST udev-syntax-20051016.tar.bz2 1161 BLAKE2B c8274fbe552bdf54f5d241b270512df8d95f43ccd4da2e9c794d7470e77d5399dc35ba396b2beddf752e656cd889107fa10d792be11c4dccba0adea4f8418727 SHA512 3952cddd2598eb4e09fd6bc7538419c9dbb3eb94d55a81418fc66b5c3fb46f34853d4b97a5475f3330b752d4dbdd3bcf22a3f47c73d1d3e18b5efcc2b4696e34
+EBUILD udev-syntax-20051016-r2.ebuild 567 BLAKE2B 59d1270555e4e474bcbc81e4f060a1abe60f4632ac0d150781e2f8d8c1e8da0b58dd5e2c9fa81be283162320f940c376304775d25a549c69e6491888255986a7 SHA512 a7e7d921e63a991c329e9f4b598c1eebe0aa6dc53735f644e020311edcf674cacd695fb418795fc14bf95b108fc30d0c58a8f20350ad040771c3a00872912ec2
+MISC metadata.xml 346 BLAKE2B 28b85271f3e53d5f31591cdae5ae0fd675c580019a44b0c769f32aa09da0324a8fd35787f5802747d721f5cac91a94ecb97976faa668c4859627d016efaf99c0 SHA512 c9cf56d93687fad1a2ae0d37518f46704a481a5ed288baf5e714ee4898f1ef304101453e2f53a05e5e079bd2e042ee403546e8f8c2787a92852910162c3150f0
diff --git a/app-vim/udev-syntax/files/udev-syntax-20051016-ftdetect.patch b/app-vim/udev-syntax/files/udev-syntax-20051016-ftdetect.patch
new file mode 100644
index 000000000000..3792be01ce23
--- /dev/null
+++ b/app-vim/udev-syntax/files/udev-syntax-20051016-ftdetect.patch
@@ -0,0 +1,6 @@
+diff -ru udev-syntax-20051016/ftdetect/udev.vim udev-syntax-20051016/ftdetect/udev.vim
+--- udev-syntax-20051016/ftdetect/udev.vim 2007-01-10 16:11:32.876871120 +0100
++++ udev-syntax-20051016/ftdetect/udev.vim 2007-01-10 16:12:04.412703024 +0100
+@@ -1,4 +1,4 @@
+-au BufNewFile,BufRead *udev.rules* set filetype=udev
++au BufNewFile,BufRead *udev/rules.d* set filetype=udev
diff --git a/app-vim/udev-syntax/metadata.xml b/app-vim/udev-syntax/metadata.xml
new file mode 100644
index 000000000000..77e95b35d8e7
--- /dev/null
+++ b/app-vim/udev-syntax/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Vim syntax highlighting for udev.rules files.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-vim/udev-syntax/udev-syntax-20051016-r2.ebuild b/app-vim/udev-syntax/udev-syntax-20051016-r2.ebuild
new file mode 100644
index 000000000000..85154af6b846
--- /dev/null
+++ b/app-vim/udev-syntax/udev-syntax-20051016-r2.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: syntax highlighting for udev rules files"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=1381"
+LICENSE="vim"
+KEYWORDS="amd64 hppa ~mips ppc sparc x86"
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides syntax highlighting for udev.rules files. These files
+are automatically detected by filename; manual loading is also possible,
+via :set filetype=udev"
+
+PATCHES=( "${FILESDIR}/${P}-ftdetect.patch" )