summaryrefslogtreecommitdiff
path: root/app-vim/txtfmt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/txtfmt
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/txtfmt')
-rw-r--r--app-vim/txtfmt/Manifest5
-rw-r--r--app-vim/txtfmt/metadata.xml8
-rw-r--r--app-vim/txtfmt/txtfmt-2.4-r1.ebuild21
-rw-r--r--app-vim/txtfmt/txtfmt-3.1.ebuild21
4 files changed, 55 insertions, 0 deletions
diff --git a/app-vim/txtfmt/Manifest b/app-vim/txtfmt/Manifest
new file mode 100644
index 000000000000..3d9d88c9de83
--- /dev/null
+++ b/app-vim/txtfmt/Manifest
@@ -0,0 +1,5 @@
+DIST txtfmt-2.4.tar.gz 127123 BLAKE2B c7623a462ae9a2562b9455ca94b013bc1555bb13d50b37f0edc27a297a420d24462e0f6a8140c8e18fd89ec400276b3fdbb5f76ea164f2e857f3849bf232c9f7 SHA512 4f3a32c34b11477a7b78fca47367754093b04dbe60bdfee16d2f05c992a82f9f64fb82b8dc811afd43fd4206f426c88ade95943cc1686e6bf57813596b9652f8
+DIST txtfmt-3.1.tar.gz 172348 BLAKE2B aa44aef49665f034dcb0528bc6795f716540088b59e026bb079e49e5d2b9f6034f99afa220cb63b7e534257e2fc249c779b2ad0fb8ef01d3fa99e609b70e059e SHA512 bdef5350626ee5251fbf3cb4a4270e72f0b8ab29948f0469cfadbcf0735ccd7c104b34a25e43d4ff147ed48de3667fba472080f81f72d5a4687467e5c44af5d1
+EBUILD txtfmt-2.4-r1.ebuild 494 BLAKE2B 544795019ce148e5205abfb875cf089e6685df151154f1b1f1e14d18157e9d53b87067d6e819d75cf2f3e544d2ed0fa453220d0f1c08f877edf26d7c0a3f8167 SHA512 9ed7c98d43b353df1a79397a314ba49498971b86fa092c21eef63c8b1d6da94423354e795a98915eb7125f9892900c74d1d64c5894bed46c93015f93d89c871f
+EBUILD txtfmt-3.1.ebuild 494 BLAKE2B 00b2bab10554cbd0e1492d71ceee9cb266ec4e50addab0226e47272f5144c146a4cf0c7aa5806f7c5a8b7720ad67dcb2230ad390cf17595b3887d8ac83e428f6 SHA512 6cc89e452783dea9206d1da9a59b176b11ea263ab24b6e5242542b42e3eb1e2f9b315c75c445ca0701de1aae2d9e7a694aee957d62cdfd807f96c4888cd49368
+MISC metadata.xml 249 BLAKE2B 7ae6eac3ca23edbcbaa6aee682bb4aec155e3166f169eef8e4400e59fa56113ecc3593680d55cc57f08a4a718963dd3d0bb804bd1e8771ed60a4bebaae9db281 SHA512 4051dd059d975d2e1799125f7defbf5a62a168241d8b83d83710592efd60808800951c4fd6da1294044d7e7ec6b757b8d50593fd076696f826dec761e99645c7
diff --git a/app-vim/txtfmt/metadata.xml b/app-vim/txtfmt/metadata.xml
new file mode 100644
index 000000000000..5c000c763084
--- /dev/null
+++ b/app-vim/txtfmt/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-vim/txtfmt/txtfmt-2.4-r1.ebuild b/app-vim/txtfmt/txtfmt-2.4-r1.ebuild
new file mode 100644
index 000000000000..4adcc7962d62
--- /dev/null
+++ b/app-vim/txtfmt/txtfmt-2.4-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: rich text highlighting in vim"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=2208"
+SRC_URI="https://www.vim.org/scripts/download_script.php?src_id=13856 -> ${P}.tar.gz"
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+S=${WORKDIR}
+
+src_prepare() {
+ default
+ rm indent_patch.txt || die
+}
diff --git a/app-vim/txtfmt/txtfmt-3.1.ebuild b/app-vim/txtfmt/txtfmt-3.1.ebuild
new file mode 100644
index 000000000000..97b915a6b3ba
--- /dev/null
+++ b/app-vim/txtfmt/txtfmt-3.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: rich text highlighting in vim"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=2208"
+SRC_URI="https://www.vim.org/scripts/download_script.php?src_id=24489 -> ${P}.tar.gz"
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+S=${WORKDIR}
+
+src_prepare() {
+ default
+ rm indent_patch.txt || die
+}