summaryrefslogtreecommitdiff
path: root/app-vim/tlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/tlib
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/tlib')
-rw-r--r--app-vim/tlib/Manifest3
-rw-r--r--app-vim/tlib/metadata.xml11
-rw-r--r--app-vim/tlib/tlib-1.20.ebuild23
3 files changed, 37 insertions, 0 deletions
diff --git a/app-vim/tlib/Manifest b/app-vim/tlib/Manifest
new file mode 100644
index 000000000000..828c1aad2198
--- /dev/null
+++ b/app-vim/tlib/Manifest
@@ -0,0 +1,3 @@
+DIST tlib-1.20.tar.gz 111202 BLAKE2B 0ee6c662e1658607706516adab9b770942ec948633a75879b5a516b46989a34744acde52d10d5b2ea58af6e7215f1241b18c53267d643d4c2e08da425a93169e SHA512 d8a344483da2a174324dc81472b5d3bdb811e54af22a1599c5567019d33bafdf499845d3efeabf081ecf17dc6965c69640a6a01b208811529e86266ba1871218
+EBUILD tlib-1.20.ebuild 566 BLAKE2B e2b86ca767d1afabe247cb4f18cbc09cd6f43bba431e826b9f28b419cb0cb162bf6f5adcb544916f2b216d2a975361e96e2a5bd838d417e1ffa24257215d8b3a SHA512 658fb2ce850438a65f1b59a1b70298372fa133e004559a7a6917a892e923e95ca8d90ae88f45b1722cf99407566bb45dde41bc485cad8ba0e09653e01af7db61
+MISC metadata.xml 329 BLAKE2B 87f979ae53b0fca4bbf6966613d9ef71365ed69a0b790bd41d526536f3e04b63e435dea3647c7b19fc31ec81bb8df70c1d830c6ec0545f1a5f63f3c1da14d923 SHA512 d36d9443ce025d73d277cc67387418ad73458be408932bf200609b6fa133b06b87598377866c89b8f9606674b54540b19c6f63afdc5ca9696225f1976bcdab48
diff --git a/app-vim/tlib/metadata.xml b/app-vim/tlib/metadata.xml
new file mode 100644
index 000000000000..5eb011848cb6
--- /dev/null
+++ b/app-vim/tlib/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tomtom/tlib_vim</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/tlib/tlib-1.20.ebuild b/app-vim/tlib/tlib-1.20.ebuild
new file mode 100644
index 000000000000..3b64cc06f5e7
--- /dev/null
+++ b/app-vim/tlib/tlib-1.20.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit vim-plugin
+
+MY_PN=${PN}_vim
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="vim plugin: a library of utility functions"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=1863 https://github.com/tomtom/tlib_vim"
+SRC_URI="https://github.com/tomtom/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+KEYWORDS="amd64 x86"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ rm -r test samples addon-info.json || die
+}