summaryrefslogtreecommitdiff
path: root/app-vim/tcomment
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-15 04:49:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-15 04:49:10 +0100
commitefca79f216bfeffd55e7731fbf24126d093e1084 (patch)
treef19ba31d8686b3de4192db3e4c4dc9f3d9af54b5 /app-vim/tcomment
parentea7f3f690b55cdfa8b2d350b03c1dfc0c8357a51 (diff)
gentoo auto-resync : 15:09:2023 - 04:49:10
Diffstat (limited to 'app-vim/tcomment')
-rw-r--r--app-vim/tcomment/Manifest3
-rw-r--r--app-vim/tcomment/tcomment-4.00.ebuild26
-rw-r--r--app-vim/tcomment/tcomment-9999.ebuild30
3 files changed, 28 insertions, 31 deletions
diff --git a/app-vim/tcomment/Manifest b/app-vim/tcomment/Manifest
index ba009183d101..613a63d993fe 100644
--- a/app-vim/tcomment/Manifest
+++ b/app-vim/tcomment/Manifest
@@ -1,4 +1,5 @@
DIST tcomment-3.08.1.tar.gz 49918 BLAKE2B df63a01432101e018a39f7b54dec0b91b415263e2b6c0f3e63521e1abe2247a005a1fc900cd6d18cfd908f75ae4b5767a5f7dc21ae620985d3465676c456a389 SHA512 609d5eb1e7785fb1af829000ab27ab63ac2bb7550bcd0f91c7c35f0a8c4b879e5348745f57b11d1e24d37920056ca55da8863e15e40d6fe289617d5d898a4177
+DIST tcomment-4.00.tar.gz 58709 BLAKE2B 64285c64d65e7308e3cb34494f1b49584f54707ba9f4e86a40a72c1434670819c412b68e4a30f296ce531913b054d482f5743ee7e6fd81baa5c3ee1d46dc8d01 SHA512 b072ec4b136ef6ea14e91883a77b036a26b2e2c0f6cabdce70e4aea2cf37a2c4b7becc0770ddfc8b7260a52cda729a0e4b8ff4a067c81bcbbe0f0e896b9e66c4
EBUILD tcomment-3.08.1.ebuild 718 BLAKE2B 48529193db40c3ac956c74783f9357bc4b43addcadd4e07017570781fe0ee5f480e174fcea0a0cbb084e7261284ed40519a8880b3eb0e2ac6533f1bb0c764ee7 SHA512 2f2d941989a22a4df80a3c1751edf377386fdcf4ee8165a5cbad84bc18cb89f230ac9c44f5b6532a8fcd81c6c0a83adaece09bde23788c48267cdc4a8f8824cf
-EBUILD tcomment-9999.ebuild 720 BLAKE2B 9b364afe92d824cb99cbe6bed8a7278c8d3abfdb1deacba54d4a56ec3acea74ac31e6978ea7ed927c2e227ae2cbabe8748092ec879bce10b843c70bf26c58544 SHA512 0754fe5b7c770757d1112182f93d41ccb34184192894105a53c6f42b6890fd54c35d4c06dd746ac17e2fc6ed38f45b8aeccbb3579fb13d5c1f4a304186761374
+EBUILD tcomment-4.00.ebuild 602 BLAKE2B beb7a5991e9dbe896c1604fa04a871dbc6284d998f32023cfb55a09c317cc864cc36326597e7fbffba9e412c696899e16ba1e9508fd92b8422c31cc65cabc403 SHA512 14c19be1e750faf8feb083e0f549e0697fce48911b02db3660be86d6eb69d5bb958d1351fa504fd6d44a087f6bde7569629f09dc35770726769f97eaff3531b3
MISC metadata.xml 344 BLAKE2B 00d1070b4a88d315b50e0651832e4431ca1819fe4da87119fc7015bafa9a2b53ea9442e75e7675fbe5425bf9cdbbf2c2001837c0ef052276c6f8e252ed7863a0 SHA512 8e018a6fe184a49f874e6c4349d8bf2e356a0260e90d2637981fdd2360d7e29ab5c9d91bd62a37706f9221c11b17f44bdabf6ed322e964fb3872336bba94c775
diff --git a/app-vim/tcomment/tcomment-4.00.ebuild b/app-vim/tcomment/tcomment-4.00.ebuild
new file mode 100644
index 000000000000..be5dacfaeb75
--- /dev/null
+++ b/app-vim/tcomment/tcomment-4.00.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+MY_PN="tcomment_vim"
+
+DESCRIPTION="vim plugin: an extensible and universal comment toggler"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=1173
+ https://github.com/tomtom/tcomment_vim"
+SRC_URI="https://github.com/tomtom/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+DOCS=( CHANGES.TXT README )
+
+src_prepare() {
+ default
+ rm -r etc spec addon* || die
+}
diff --git a/app-vim/tcomment/tcomment-9999.ebuild b/app-vim/tcomment/tcomment-9999.ebuild
deleted file mode 100644
index 123c92cde935..000000000000
--- a/app-vim/tcomment/tcomment-9999.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit vim-plugin
-
-MY_PN="tcomment_vim"
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/tomtom/tcomment_vim.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/tomtom/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
- S="${WORKDIR}/${MY_PN}-${PV}"
-fi
-
-DESCRIPTION="vim plugin: an extensible and universal comment toggler"
-HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=1173 https://github.com/tomtom/tcomment_vim"
-LICENSE="GPL-3"
-
-VIM_PLUGIN_HELPFILES="${PN}.txt"
-
-DOCS=( CHANGES.TXT README )
-
-src_prepare() {
- default
- rm -r etc spec addon* || die
-}