summaryrefslogtreecommitdiff
path: root/app-vim/tasklist
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/tasklist
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/tasklist')
-rw-r--r--app-vim/tasklist/Manifest3
-rw-r--r--app-vim/tasklist/metadata.xml15
-rw-r--r--app-vim/tasklist/tasklist-1.0.1.ebuild19
3 files changed, 37 insertions, 0 deletions
diff --git a/app-vim/tasklist/Manifest b/app-vim/tasklist/Manifest
new file mode 100644
index 000000000000..85ec58318e8f
--- /dev/null
+++ b/app-vim/tasklist/Manifest
@@ -0,0 +1,3 @@
+DIST tasklist-1.0.1.tar.gz 4066 BLAKE2B d55e12f28546f400b34e11636814205e94c3c82656a068c9774fb23fcfd336fae059efcf307043b6bcbaccb939a4a4ed8d02c9a5944381bece096c57f6092ade SHA512 623ec5b147e485abe3e246796a6ed67dd8325ef37708e589c4568897da10ba70076eb5dffd9fb9333fc29d045c316cf382950de13f616873334fc734875600b9
+EBUILD tasklist-1.0.1.ebuild 448 BLAKE2B 0f02ae5f3206b69f4a07d7bd34d2d902033bc072e2586acc79ae64ef9a1d4cae028697df017acc15718ac80f36ddb6664ad2a89deeac65a17c53f7fa59c18d18 SHA512 2ddd17c8ed2a27feb12eb8c6fb0e1a089d9e940a17962d34f7c54e947aa715f30f3d6267ec806ca2136f16e63ad485633e7a8efc6fd677b8a526b74031a408a4
+MISC metadata.xml 450 BLAKE2B 3a688d7ebb054fc8ee455e92001c40c1325c614b18800f6b31d7dca2d47621016fc831e4785745fae6bce770b3eec6d403b5de3a4b4cf373f60a17b97cb80e99 SHA512 2f047ee53729d6cf9fa63861c3f4246767541fbc16d21df0f6b75bb153a77f0e2b68d67e20a1544944f19ffb00e8363c6a374c9d414c242cf218aaf0f3ce69af
diff --git a/app-vim/tasklist/metadata.xml b/app-vim/tasklist/metadata.xml
new file mode 100644
index 000000000000..550fea50c1c9
--- /dev/null
+++ b/app-vim/tasklist/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>monsieurp@gentoo.org</email>
+ <name>Patrice Clement</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">vim-scripts/tasklist.vim</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/tasklist/tasklist-1.0.1.ebuild b/app-vim/tasklist/tasklist-1.0.1.ebuild
new file mode 100644
index 000000000000..b855acd97181
--- /dev/null
+++ b/app-vim/tasklist/tasklist-1.0.1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="Highlight FIXME/TODO/CUSTOM keywords in a separate list"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=2607"
+SRC_URI="https://github.com/vim-scripts/${PN}.vim/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_unpack() {
+ default
+ mv vim-* "${P}" || die
+}