summaryrefslogtreecommitdiff
path: root/app-vim/tasklist
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-vim/tasklist
reinit the tree, so we can have metadata
Diffstat (limited to 'app-vim/tasklist')
-rw-r--r--app-vim/tasklist/Manifest4
-rw-r--r--app-vim/tasklist/metadata.xml15
-rw-r--r--app-vim/tasklist/tasklist-1.0.1.ebuild19
3 files changed, 38 insertions, 0 deletions
diff --git a/app-vim/tasklist/Manifest b/app-vim/tasklist/Manifest
new file mode 100644
index 000000000000..501c9f9bdf06
--- /dev/null
+++ b/app-vim/tasklist/Manifest
@@ -0,0 +1,4 @@
+DIST tasklist-1.0.1.tar.gz 4066 SHA256 70c676e71d3fe6f98ff99b2ad9df64ed8b7ae2f526dd83f5fe938e521170c603 SHA512 623ec5b147e485abe3e246796a6ed67dd8325ef37708e589c4568897da10ba70076eb5dffd9fb9333fc29d045c316cf382950de13f616873334fc734875600b9 WHIRLPOOL 4d59eaad371860a2a3d8fff861ee663b4fbcb40e80e3f14d29c386d64938b063228b12e13a67869d7f1ef24736c75bb652215add39c749b370f75c8ed74472ba
+EBUILD tasklist-1.0.1.ebuild 447 SHA256 c614876f18ccb7ffdb6f706f8d96fbc0f746ba3e6528c2da6dc8b067fb9d0221 SHA512 530bb7f503cc4e402bc288a0fdc61aaa5fbeac7e7521168679881cbd480cd45b73de5a4de424d92ab87b46455cadd1d143d08eadd02e14af35eba09645f4cd9c WHIRLPOOL c44a3e025960fe24c64437f7ac3c45369a48c0e69394a102ef074e95f96173860c021b98a216ee40c6ecaddea763778a505a90bb1b9d294d138f4d9d9082495f
+MISC ChangeLog 383 SHA256 2d475834ca2f13450b9b57be2888aa16864d1786bd004420059bef3bb1839fd9 SHA512 c59659817125d7f8f9474b6d9bf21547758103e037f1a8727a70b977e9d5f2e9f3ad65a87e58ac923d2658346ebe20374279987333f24938135c904deaa17405 WHIRLPOOL 7548745c036dc7c45e0e15d72a42a0a3bcc4e2056da794c19e210e81ab704658ad16286734be83e3228e6d0d474079c8f3b52b52abb44608340ee769b4cd08bb
+MISC metadata.xml 450 SHA256 95956fff6968c1847aef8ad31800a7ff176229490df3e006cd16eac273b3a96e SHA512 2f047ee53729d6cf9fa63861c3f4246767541fbc16d21df0f6b75bb153a77f0e2b68d67e20a1544944f19ffb00e8363c6a374c9d414c242cf218aaf0f3ce69af WHIRLPOOL af97fbd1b08f50de5d93ca087ebed73b568206332992d4d0cef3e2cfa9843e5281570ca84eb531aa18acf200e2a818a4d5a61fca2f4206bf3914de6b4272b6e2
diff --git a/app-vim/tasklist/metadata.xml b/app-vim/tasklist/metadata.xml
new file mode 100644
index 000000000000..550fea50c1c9
--- /dev/null
+++ b/app-vim/tasklist/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>monsieurp@gentoo.org</email>
+ <name>Patrice Clement</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">vim-scripts/tasklist.vim</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/tasklist/tasklist-1.0.1.ebuild b/app-vim/tasklist/tasklist-1.0.1.ebuild
new file mode 100644
index 000000000000..165b0a12dfa9
--- /dev/null
+++ b/app-vim/tasklist/tasklist-1.0.1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="Highlight FIXME/TODO/CUSTOM keywords in a separate list"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2607"
+SRC_URI="https://github.com/vim-scripts/${PN}.vim/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_unpack() {
+ default
+ mv vim-* "${P}" || die
+}