summaryrefslogtreecommitdiff
path: root/app-vim/syntastic
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /app-vim/syntastic
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'app-vim/syntastic')
-rw-r--r--app-vim/syntastic/Manifest2
-rw-r--r--app-vim/syntastic/syntastic-3.9.0.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/app-vim/syntastic/Manifest b/app-vim/syntastic/Manifest
index 82fc9b4f8c40..c550a6ec5993 100644
--- a/app-vim/syntastic/Manifest
+++ b/app-vim/syntastic/Manifest
@@ -1,4 +1,6 @@
DIST syntastic-3.8.0.tar.gz 253425 BLAKE2B a003b9166aba2915b5421ac02544d128b8befca0af4f15c880f56ad046fad0ca7c202e6f7dda44588a6ad4ac3b77a3ed3602613855c6755261b5941d45464eff SHA512 b2f7fb07d457169a397a1ed42141e099cad14ded0b43f54a11060f2952843387396fcc539ffc9aaa1aa137ae62801e346a73c6de6035a0504706c59e40acef5c
+DIST syntastic-3.9.0.tar.gz 263275 BLAKE2B 574cf958b859a108cdfdffed29b3ff0f0903dac5c7fbc497e2c69831ee35532d317bde0ab827dda828ee7cb3cc13ab9176c9ea6ea233e03e7b3fcb5b7c49757e SHA512 04cee939226940bb95935434b7aba42a3419b8b7b73d5fa9052a6aaccec5d0724c4e3634edd56573d0080b31baf49c1a00811c6f88e4fbbdea7e761e5707dcb5
EBUILD syntastic-3.8.0.ebuild 968 BLAKE2B 192fbe2617ebebb7972c10ae0dc49ab9cabdad96bb0940b0cb324137cd222a19c4d290013d1c2e99b2096386b9cdfdeb01bf6fdb32274be808c6918938ebf38f SHA512 6c2b2d068b07a2a7ec8677ea4582a626b19ea066d7801eace97a4a0ea4431329c31694841fcf1687af43ab72d6ed64b6ca2635e24b8685e7c9173b538d6b8e21
+EBUILD syntastic-3.9.0.ebuild 970 BLAKE2B a5a68d1c7af2c455cc0dbd23d60259ec5ab007f7f3eeb479da216e9c5454abd686e4055f9f0a505f232b33bd2a208e805cc2a1419b53c7cb38c3bd520b94ef45 SHA512 005215fa23cdec125e9888d109ba5a59d47f32540512f9c8d08d32a098aea1a774f6284374f89250c8a8fdc50a13df6e1f1ee13b531ec6ab653ed490e6705f47
EBUILD syntastic-9999.ebuild 970 BLAKE2B a5a68d1c7af2c455cc0dbd23d60259ec5ab007f7f3eeb479da216e9c5454abd686e4055f9f0a505f232b33bd2a208e805cc2a1419b53c7cb38c3bd520b94ef45 SHA512 005215fa23cdec125e9888d109ba5a59d47f32540512f9c8d08d32a098aea1a774f6284374f89250c8a8fdc50a13df6e1f1ee13b531ec6ab653ed490e6705f47
MISC metadata.xml 344 BLAKE2B dae79c875127b2b2034e1f41e65b94b9ff472f58b9d5ce8aa3920db428d468a0015a6ce252522fc158b9823fbff2bd7ff3ba1facc8cf061b775dfaca2b600f70 SHA512 ef01f82c783947320dcb2bdafbcc9545cd2ead7fedb18ccfda335c13d246f980cdd6b31c6e5a2f78f6f75b1ffbc18471a8e8f6c615ba1a75180b362602b6cf85
diff --git a/app-vim/syntastic/syntastic-3.9.0.ebuild b/app-vim/syntastic/syntastic-3.9.0.ebuild
new file mode 100644
index 000000000000..6776db4e00ef
--- /dev/null
+++ b/app-vim/syntastic/syntastic-3.9.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vim-plugin
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/scrooloose/syntastic.git"
+else
+ SRC_URI="https://github.com/scrooloose/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="vim plugin: syntax checking using external tools"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=2736 https://github.com/scrooloose/syntastic/"
+LICENSE="WTFPL-2"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+src_prepare() {
+ default
+ rm -r _assets LICENCE README.markdown || die
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "Syntastic has many optional dependencies depending on the type"
+ elog "of syntax checking being performed. Look in the related files in"
+ elog "the syntax_checkers directory to help figure out what programs"
+ elog "different languages need."
+ fi
+}