summaryrefslogtreecommitdiff
path: root/app-vim/syntastic
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /app-vim/syntastic
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'app-vim/syntastic')
-rw-r--r--app-vim/syntastic/Manifest4
-rw-r--r--app-vim/syntastic/syntastic-3.10.0.ebuild33
-rw-r--r--app-vim/syntastic/syntastic-9999.ebuild2
3 files changed, 37 insertions, 2 deletions
diff --git a/app-vim/syntastic/Manifest b/app-vim/syntastic/Manifest
index 31dd262afc3d..2dcd235cd2f3 100644
--- a/app-vim/syntastic/Manifest
+++ b/app-vim/syntastic/Manifest
@@ -1,4 +1,6 @@
+DIST syntastic-3.10.0.tar.gz 268037 BLAKE2B 90f055a919d8b2407bda2daa3570e3fc9e2970905f65eca52f0a3a01c878eb98e2197ed017d272af298b42206f93fc73cfcdd196a638f9c536d4af44de6209d2 SHA512 c19f2f7b709bbd9aab30da0f493e773e3e56d97efa0e558af7a97fcda1bb2f091355e06d24971f1bde5b321e027b6fc279b1d473599b77db0e996bf7a247fcd8
DIST syntastic-3.9.0.tar.gz 263275 BLAKE2B 574cf958b859a108cdfdffed29b3ff0f0903dac5c7fbc497e2c69831ee35532d317bde0ab827dda828ee7cb3cc13ab9176c9ea6ea233e03e7b3fcb5b7c49757e SHA512 04cee939226940bb95935434b7aba42a3419b8b7b73d5fa9052a6aaccec5d0724c4e3634edd56573d0080b31baf49c1a00811c6f88e4fbbdea7e761e5707dcb5
+EBUILD syntastic-3.10.0.ebuild 952 BLAKE2B 97fe478ce3d83b442f2a998ce57be8308c6c2b00de7392409c17f4d1dbd53fb2f9b62b00dbb26edce8dcdb54675845347a4876d01fef126b4a27b382b8c64738 SHA512 e521c6c3cf265f9dc75343190155f50931a21127d34e6ad131071c223e7673946e0fb578cce29fa69de324425b55e216877ffbd3a259043246e97e271d51645b
EBUILD syntastic-3.9.0.ebuild 950 BLAKE2B e879c506e98ebe8dbcfe3c6ea7af07ef95cbb634c569b1dff897b3ab8b03ab688b08500f8ccd90e34224780c8c8e916d8689c2ffc674265fc7f50a0645d659e4 SHA512 29ab862ae311bb8695316496758c1db391a18e343ffef7f788e4509e3347cdaf05ddb60e7203cce90c8268be15621f03c3f3a71fc155f6f7b027074aac9e88b3
-EBUILD syntastic-9999.ebuild 952 BLAKE2B 6221b3310d7f89e0668e3fb7baf26256984feb7888a700deec0c8bc07c2e21e4d15a107c0ceaf68a1a2efe05d5605c3e12867bccf34b43bd81e3371adf1193be SHA512 7a4d05a0091585bcd030e5ee055711ebb8b703aa9059e7b088b2bd898b0cff702cfdc2d0cfe2d0b4ee095d29d62861fed18eeae7b9220d9e107644b827d79d81
+EBUILD syntastic-9999.ebuild 952 BLAKE2B 97fe478ce3d83b442f2a998ce57be8308c6c2b00de7392409c17f4d1dbd53fb2f9b62b00dbb26edce8dcdb54675845347a4876d01fef126b4a27b382b8c64738 SHA512 e521c6c3cf265f9dc75343190155f50931a21127d34e6ad131071c223e7673946e0fb578cce29fa69de324425b55e216877ffbd3a259043246e97e271d51645b
MISC metadata.xml 345 BLAKE2B 8787d399c07d84a15c1e544c69671e591237929e4079477fea08dbc4c81b9b7201b92ff5e35363d843d55fcf493f3805f5b226940174b9b96f1e49d494407dbc SHA512 fc0126da5cace699a4ac83539e8b1fe61bb95d79761e9b9913c300e822bfc13adc14adfb2c3ab006a3effa681d1d6bc462a857ccfa87cad3ffe0c2991d38036c
diff --git a/app-vim/syntastic/syntastic-3.10.0.ebuild b/app-vim/syntastic/syntastic-3.10.0.ebuild
new file mode 100644
index 000000000000..d109f7f00959
--- /dev/null
+++ b/app-vim/syntastic/syntastic-3.10.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit vim-plugin
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vim-syntastic/syntastic.git"
+else
+ SRC_URI="https://github.com/vim-syntastic/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="vim plugin: syntax checking using external tools"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=2736 https://github.com/vim-syntastic/syntastic/"
+LICENSE="WTFPL-2"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+src_prepare() {
+ default
+ rm -r _assets || die
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "Syntastic has many optional dependencies depending on the type"
+ elog "of syntax checking being performed. Look in the related files in"
+ elog "the syntax_checkers directory to help figure out what programs"
+ elog "different languages need."
+ fi
+}
diff --git a/app-vim/syntastic/syntastic-9999.ebuild b/app-vim/syntastic/syntastic-9999.ebuild
index d35f80b3f9ed..d109f7f00959 100644
--- a/app-vim/syntastic/syntastic-9999.ebuild
+++ b/app-vim/syntastic/syntastic-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7