summaryrefslogtreecommitdiff
path: root/app-vim/splice/splice-1.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-vim/splice/splice-1.0.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-vim/splice/splice-1.0.1.ebuild')
-rw-r--r--app-vim/splice/splice-1.0.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-vim/splice/splice-1.0.1.ebuild b/app-vim/splice/splice-1.0.1.ebuild
new file mode 100644
index 000000000000..60628b4e9474
--- /dev/null
+++ b/app-vim/splice/splice-1.0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit vim-plugin python-single-r1
+
+DESCRIPTION="vim plugin: resolve conflicts during three-way merges"
+HOMEPAGE="https://sjl.bitbucket.org/splice.vim/ http://vim.sourceforge.net/scripts/script.php?script_id=4026"
+
+LICENSE="MIT"
+KEYWORDS="amd64 x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ || (
+ app-editors/vim[python]
+ app-editors/gvim[python]
+ )"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ rm LICENSE.markdown || die
+}
+
+src_install() {
+ vim-plugin_src_install
+ python_optimize "${ED}"/usr/share/vim/vimfiles/autoload/splicelib
+}