summaryrefslogtreecommitdiff
path: root/app-vim/slimv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/slimv
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/slimv')
-rw-r--r--app-vim/slimv/Manifest5
-rw-r--r--app-vim/slimv/metadata.xml28
-rw-r--r--app-vim/slimv/slimv-0.9.12-r1.ebuild33
-rw-r--r--app-vim/slimv/slimv-0.9.13_p20170910.ebuild41
4 files changed, 107 insertions, 0 deletions
diff --git a/app-vim/slimv/Manifest b/app-vim/slimv/Manifest
new file mode 100644
index 000000000000..eb32fc60e48f
--- /dev/null
+++ b/app-vim/slimv/Manifest
@@ -0,0 +1,5 @@
+DIST slimv-0.9.12.tar.bz2 614025 BLAKE2B 8740e905a12b28715f953fecfdde3c7d6b4eeb74fc190c433bdb7120b3a6af5d5c9c2ced3f57a43ab8b9bd1402cb15462892343bb621f8b56453d98a909ff882 SHA512 7ccf617780c5d6b8d25738546cb9df6986b4409748a5938e8d9112b057d34626a6b8525fb8622db06d0f300d6ec38f7513ef2c0e49df3bcd89614888887ca057
+DIST slimv-0.9.13_p20170910.tar.gz 634493 BLAKE2B af7963e1d1b60b20294c935ecd076220777eec333b4e91bac82a111b727ce71c312c347b865f9e0c9072c0f94b40dc920b15feaf10f8683e1bba7590a177e62e SHA512 562e08866d62a6af5c20064a4533da7f0577ceb43391fac59acc0bb9c76319e3520c951c325277edbb2d0461fa227b91456c54ec5d9d1e3bca18d344f3e9a5e2
+EBUILD slimv-0.9.12-r1.ebuild 899 BLAKE2B 778bc0eb8febd46e7b42943bb4fcc4a1257bf136a342891655b6c80f2f496ef2ac62f6eddffe5c63ea75323188a05c2eb5906951213f41b6383e638454bc0908 SHA512 6549c954e0f2f2031b32470d8cd0061f01dcc0043af885e195d1b42fb9224436e5e79ddd94328c5d357c7aaee71ea370f2f4fee0f5ee9596e4d2a5e0fbe07b8b
+EBUILD slimv-0.9.13_p20170910.ebuild 1001 BLAKE2B 598a50667d0c3155f3c516eab3a677e39c94a069ef998aa167d7feb91ff6037eab2db25728dd0db28e2f1464b1808987c2f271223896ea37e4a2736025bd7cbc SHA512 18da1cc235a2c0838e5fc1ad670d6b4afed98ae22e5c5847be636e4d29cedb0f60187d676106558047bb241c80a39307426047a79b2cf6327821fa46d773a0a3
+MISC metadata.xml 1220 BLAKE2B 7d60a456299acdd198b51276a1016fec37007bdb6220efaa786889b0d046de73d14724e2a8bd5efaec84e0c850ff69bdaf344bbedcafa132a0a8c0c45fad051e SHA512 11c6fb3a83ea65ea97e57e70b24d9e011d48fb456bff15ea8b501e0dab767f73c78ae1c63e662423599252dee9969c1983b17fd1505533b3ee26f3afde2a3b29
diff --git a/app-vim/slimv/metadata.xml b/app-vim/slimv/metadata.xml
new file mode 100644
index 000000000000..0f0e597cc1b6
--- /dev/null
+++ b/app-vim/slimv/metadata.xml
@@ -0,0 +1,28 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Slimv tries to mimic a subset of SLIME's (Superior Lisp Interaction Mode
+ for Emacs) functionality inside Vim. The script defines functions and
+ keybindings to send s-expressions to a console mode Lisp or Clojure REPL
+ (Read-Eval-Print Loop).
+
+ Slimv runs its own REPL or connects to a running REPL started by a
+ previous Slimv session, the connection is established when the first
+ Slimv command is executed (e.g. an s-expression is evaluated). The Lisp
+ REPL buffer can also be opened inside Vim as a Vim buffer with syntax
+ highlighting and autoindenting, Lisp commands may be entered in the
+ command line, just as in a regular REPL. The script also has a basic
+ support for Clojure REPL.
+
+ The script also supports a number of other features provided by SLIME
+ including profiling, paredit mode, and hyperspec lookups.
+ </longdescription>
+ <upstream>
+ <remote-id type="bitbucket">kovisoft/slimv</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/slimv/slimv-0.9.12-r1.ebuild b/app-vim/slimv/slimv-0.9.12-r1.ebuild
new file mode 100644
index 000000000000..1d601bfbaeef
--- /dev/null
+++ b/app-vim/slimv/slimv-0.9.12-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 vim-plugin vcs-snapshot
+
+DESCRIPTION="vim plugin: aid Lisp development by providing a SLIME-like Lisp and Clojure REPL"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=2531 https://github.com/kovisoft/slimv"
+SRC_URI="https://bitbucket.org/kovisoft/${PN}/get/${PV}.tar.bz2 -> ${P}.tar.bz2"
+LICENSE="public-domain"
+KEYWORDS="amd64 x86"
+
+RDEPEND="|| ( app-editors/vim[python,${PYTHON_USEDEP}] app-editors/gvim[python,${PYTHON_USEDEP}] )
+ ${PYTHON_DEPS}
+ || (
+ dev-lisp/clisp
+ dev-lang/clojure
+ dev-lisp/abcl
+ dev-lisp/clozurecl
+ dev-lisp/ecls
+ dev-lisp/sbcl
+ )"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ # remove emacs related files
+ rm -r slime swank-clojure || die
+}
diff --git a/app-vim/slimv/slimv-0.9.13_p20170910.ebuild b/app-vim/slimv/slimv-0.9.13_p20170910.ebuild
new file mode 100644
index 000000000000..9f4e50a10ec2
--- /dev/null
+++ b/app-vim/slimv/slimv-0.9.13_p20170910.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 vim-plugin vcs-snapshot
+
+# Commit Date: July 10th 2017
+COMMIT="acf9b30be71c54db4f4875d257b905941ca69ed8"
+
+DESCRIPTION="vim plugin: aid Lisp development by providing a SLIME-like Lisp and Clojure REPL"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=2531 https://github.com/kovisoft/slimv"
+SRC_URI="https://github.com/kovisoft/slimv/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ || (
+ app-editors/vim[python,${PYTHON_USEDEP}]
+ app-editors/gvim[python,${PYTHON_USEDEP}]
+ )
+ ${PYTHON_DEPS}
+ || (
+ dev-lisp/abcl
+ dev-lisp/ecls
+ dev-lisp/sbcl
+ dev-lisp/clisp
+ dev-lang/clojure
+ dev-lisp/clozurecl
+ )"
+
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ default
+ # remove emacs related files
+ rm -r slime swank-clojure || die
+}