summaryrefslogtreecommitdiff
path: root/app-vim/repeat/repeat-1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-vim/repeat/repeat-1.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-vim/repeat/repeat-1.1.ebuild')
-rw-r--r--app-vim/repeat/repeat-1.1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/app-vim/repeat/repeat-1.1.ebuild b/app-vim/repeat/repeat-1.1.ebuild
new file mode 100644
index 000000000000..be184379eb33
--- /dev/null
+++ b/app-vim/repeat/repeat-1.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit vim-plugin
+
+MY_PN="vim-repeat"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="vim plugin: use the repeat command \".\" with plugin maps"
+HOMEPAGE="https://github.com/tpope/vim-repeat/ http://www.vim.org/scripts/script.php?script_id=2136"
+SRC_URI="https://github.com/tpope/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="vim"
+KEYWORDS="amd64 x86"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ rm *.markdown || die
+}