summaryrefslogtreecommitdiff
path: root/app-vim/reload
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/reload
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/reload')
-rw-r--r--app-vim/reload/Manifest3
-rw-r--r--app-vim/reload/metadata.xml11
-rw-r--r--app-vim/reload/reload-0.6.17.ebuild22
3 files changed, 36 insertions, 0 deletions
diff --git a/app-vim/reload/Manifest b/app-vim/reload/Manifest
new file mode 100644
index 000000000000..fa711be0bd68
--- /dev/null
+++ b/app-vim/reload/Manifest
@@ -0,0 +1,3 @@
+DIST reload-0.6.17.tar.gz 7028 BLAKE2B bb8e843e1092c7e155546da5aea67280ca4b028c037547434f00e15bed29d7fae062289bc8ca506ed9be17674ce63494f72273797ff7022aa95b46405b0a4a63 SHA512 639ffcea9bf94b0a8346850078f59ff332ff6180b042d2c22662d5c637307969644607ca3f19e2648a1ef9a019788ef1f83be52b627ca6784e16d1b7bddc39cd
+EBUILD reload-0.6.17.ebuild 508 BLAKE2B a5642419a143c3b680ee272b26b84915dc48a050eb87db6ea48608a83437603049caa25c37fc8891aeab5d2583d9afd502d4bc73dfe197aab909b732ed1e6db0 SHA512 fa6ca4568cd17547e9e7a3a506911e4cad913ab9008e5b9c0d230a47e46a9ed375ce405d99fa80a25592e9913dbff601679a4aae9b25ad324eded6f7d6833e40
+MISC metadata.xml 340 BLAKE2B 56fe3809eaede079c4a3000728dad4f75d21b2cf6212517fc45b48e8882d317ba73522e8861dd9e3b94fecbe541d03e48816e69585ee9d667d4401504fc9e08d SHA512 25a88a091f9cb2756f5e28361ec31f79997114271499c3522f47ddd2a86d8dc9bba42e533e004a040b7598dc380ef84480966a1d3641e333f423a810223bc1ec
diff --git a/app-vim/reload/metadata.xml b/app-vim/reload/metadata.xml
new file mode 100644
index 000000000000..e94902a72acb
--- /dev/null
+++ b/app-vim/reload/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">xolox/vim-reload</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/reload/reload-0.6.17.ebuild b/app-vim/reload/reload-0.6.17.ebuild
new file mode 100644
index 000000000000..b55fba2bf075
--- /dev/null
+++ b/app-vim/reload/reload-0.6.17.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: automatic reloading of vim scripts"
+HOMEPAGE="http://peterodding.com/code/vim/reload/"
+SRC_URI="https://github.com/xolox/vim-${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+KEYWORDS="amd64 x86"
+
+RDEPEND=">=app-vim/vim-misc-1.8.5"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+S=${WORKDIR}/vim-${P}
+
+src_prepare() {
+ rm addon-info.json *.md || die
+}