summaryrefslogtreecommitdiff
path: root/app-vim/rainbow_parentheses
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/rainbow_parentheses
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/rainbow_parentheses')
-rw-r--r--app-vim/rainbow_parentheses/Manifest3
-rw-r--r--app-vim/rainbow_parentheses/metadata.xml15
-rw-r--r--app-vim/rainbow_parentheses/rainbow_parentheses-1.0.ebuild17
3 files changed, 35 insertions, 0 deletions
diff --git a/app-vim/rainbow_parentheses/Manifest b/app-vim/rainbow_parentheses/Manifest
new file mode 100644
index 000000000000..3b9db51a3aae
--- /dev/null
+++ b/app-vim/rainbow_parentheses/Manifest
@@ -0,0 +1,3 @@
+DIST rainbow_parentheses-1.0.zip 2827 BLAKE2B 655905c1b54d5c885e1a06fe4403786b76958ba47d0facae3d3a1e657ae0a702b3f939383e2f617f5bdca9b33193dd52196eff5915236180e0d9d4a6a4e22e79 SHA512 326310058a7dd25fbd47105334cc1a6a059d40842afe48164922b7869af344dc230a5f3b329c13d5d0ae9779814507defa8d0ff56b951556e8f2bd685313e569
+EBUILD rainbow_parentheses-1.0.ebuild 465 BLAKE2B 9bd56a696c95e0a3b349333c4d4b07369904aac70e456cf7ffcfbf1dfed6baa85d32377290a8d2b7519792e3fad3e54e0343cb8fa93027d25f806ba6241e638c SHA512 26bd9fb6ed5a1ad321d80c87077b757d88c9a00ad8f053e634f603fe7352dd70ed8b26067d60cac8f49c96f459b8cc471fc2f68eae6171612095b79102668d5b
+MISC metadata.xml 454 BLAKE2B 36c6cd350f7fec2a1e473f7c9fc071943d5de82826e7cd66159542710137ecee788fcd3390d8271a36cd8c1f7a4b99e4c864dd92667e502630fc3243f03084fd SHA512 a4b31f36a2f9097b165e424cafdeb772ece04ecbfc5b7813e17ae13eb5ee4a15f1e180fa20ac722087ba2968385c766ff76be1599dd584a01d804604c732dd63
diff --git a/app-vim/rainbow_parentheses/metadata.xml b/app-vim/rainbow_parentheses/metadata.xml
new file mode 100644
index 000000000000..d73a957169b3
--- /dev/null
+++ b/app-vim/rainbow_parentheses/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>monsieurp@gentoo.org</email>
+ <name>Patrice Clement</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">kien/rainbow_parentheses.vim</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/rainbow_parentheses/rainbow_parentheses-1.0.ebuild b/app-vim/rainbow_parentheses/rainbow_parentheses-1.0.ebuild
new file mode 100644
index 000000000000..c9f0a4f2d4cd
--- /dev/null
+++ b/app-vim/rainbow_parentheses/rainbow_parentheses-1.0.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Colour parentheses to differentiate nest levels"
+HOMEPAGE="https://github.com/kien/rainbow_parentheses.vim"
+SRC_URI="https://dev.gentoo.org/~monsieurp/packages/${P}.zip"
+LICENSE="vim"
+KEYWORDS="alpha amd64 ia64 ppc sparc x86"
+
+DEPEND="app-arch/unzip"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}.vim-master"