summaryrefslogtreecommitdiff
path: root/app-vim/rails
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/rails
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/rails')
-rw-r--r--app-vim/rails/Manifest5
-rw-r--r--app-vim/rails/metadata.xml11
-rw-r--r--app-vim/rails/rails-5.1.ebuild23
-rw-r--r--app-vim/rails/rails-5.2.ebuild23
4 files changed, 62 insertions, 0 deletions
diff --git a/app-vim/rails/Manifest b/app-vim/rails/Manifest
new file mode 100644
index 000000000000..c7339bb3c12b
--- /dev/null
+++ b/app-vim/rails/Manifest
@@ -0,0 +1,5 @@
+DIST rails-5.1.tar.gz 57639 BLAKE2B 71873d4428a72b02efc1a516a8cdfebacd6505c914af54e1b59abda1db65b4a52afa7fbdb641311350068e490d08b0f850ea02701cfa02d3e60b67240e9ee84d SHA512 15aac8a66c84c939ad7628480ebae8008644a09c4901d1c20c09945232f39ccff236f4d0926dc4f902b9373bda30dc6740d76f7f580e5e74892cb16749ad5a11
+DIST rails-5.2.tar.gz 60940 BLAKE2B 315b4bc96768682fdc8012eed63c9f3881e3e647f3fb065ac3c13b767325c13ff3c69f7c92d626f6cd01705b7bd56361b4a4bbe5c1626f9db0a41233285d6f92 SHA512 0a704545b864eed46513747ab3a9f0d3537e3d6a5d01cb1cf628131f79b4b72f90e567df26364e3344adef423ccf96586367a97d0e7d4a8be9c72f54e842a810
+EBUILD rails-5.1.ebuild 560 BLAKE2B 4a0f6b31ab8602c9222f66938b4ac21a514eed7bb314fa57974e5aa7cdf8489335d8a689eefb3bd4a9913339b945fa7a7570068cce7a9b64339fb8b4e4be69cf SHA512 79d7c57c6f7c2bc1cc982809b4dd3fc662f0c01409379e4ae96b3605ed1cf0663d1afeba5383afc4052e6c5b5eaf26c02a12b7108e1745977eff4bc0ccff4e84
+EBUILD rails-5.2.ebuild 560 BLAKE2B 4a0f6b31ab8602c9222f66938b4ac21a514eed7bb314fa57974e5aa7cdf8489335d8a689eefb3bd4a9913339b945fa7a7570068cce7a9b64339fb8b4e4be69cf SHA512 79d7c57c6f7c2bc1cc982809b4dd3fc662f0c01409379e4ae96b3605ed1cf0663d1afeba5383afc4052e6c5b5eaf26c02a12b7108e1745977eff4bc0ccff4e84
+MISC metadata.xml 339 BLAKE2B 6cff8149c1b1c38a8d6b9f12d9f2840a41e643b2f602d388d81dbf7774cd3cd9485c9d91c4801d4a04e17521b9d58317dae7250683dddd78d9951cd576624ddf SHA512 6c08bc15b40f53439632423b8139d2b10cb3a3e2d237e973efb08ab95e2ab306557cea32eb11fd31aceb4d03b2392f981595d181a9c2815801bbc6938be9903c
diff --git a/app-vim/rails/metadata.xml b/app-vim/rails/metadata.xml
new file mode 100644
index 000000000000..2294b568b512
--- /dev/null
+++ b/app-vim/rails/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">tpope/vim-rails</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/rails/rails-5.1.ebuild b/app-vim/rails/rails-5.1.ebuild
new file mode 100644
index 000000000000..10a6335781c2
--- /dev/null
+++ b/app-vim/rails/rails-5.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit vim-plugin
+
+MY_PN="vim-rails"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="vim plugin: aids developing Ruby on Rails applications"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=1567 https://github.com/tpope/vim-rails/"
+SRC_URI="https://github.com/tpope/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="vim"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ rm *.markdown || die
+}
diff --git a/app-vim/rails/rails-5.2.ebuild b/app-vim/rails/rails-5.2.ebuild
new file mode 100644
index 000000000000..10a6335781c2
--- /dev/null
+++ b/app-vim/rails/rails-5.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit vim-plugin
+
+MY_PN="vim-rails"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="vim plugin: aids developing Ruby on Rails applications"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=1567 https://github.com/tpope/vim-rails/"
+SRC_URI="https://github.com/tpope/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="vim"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ rm *.markdown || die
+}