summaryrefslogtreecommitdiff
path: root/app-vim/rails/rails-5.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-vim/rails/rails-5.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-vim/rails/rails-5.2.ebuild')
-rw-r--r--app-vim/rails/rails-5.2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-vim/rails/rails-5.2.ebuild b/app-vim/rails/rails-5.2.ebuild
new file mode 100644
index 000000000000..8ccec2791abc
--- /dev/null
+++ b/app-vim/rails/rails-5.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit vim-plugin
+
+MY_PN="vim-rails"
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="vim plugin: aids developing Ruby on Rails applications"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=1567 https://github.com/tpope/vim-rails/"
+SRC_URI="https://github.com/tpope/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="vim"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ rm *.markdown || die
+}