summaryrefslogtreecommitdiff
path: root/app-vim/pytest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/pytest
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/pytest')
-rw-r--r--app-vim/pytest/Manifest3
-rw-r--r--app-vim/pytest/metadata.xml11
-rw-r--r--app-vim/pytest/pytest-1.1.4.ebuild19
3 files changed, 33 insertions, 0 deletions
diff --git a/app-vim/pytest/Manifest b/app-vim/pytest/Manifest
new file mode 100644
index 000000000000..ecedb6eebaa0
--- /dev/null
+++ b/app-vim/pytest/Manifest
@@ -0,0 +1,3 @@
+DIST pytest-1.1.4.tar.gz 10550 BLAKE2B 3da7659db866c25c57ba74f9db40c161faea228b389cc06be973778c5c389ac5ba6d46d16c2d47a4e9640e92b68344d7896400ae1b795725c95410013df55da5 SHA512 94240b763c332e5cd46169af86c6e775993a8ec48e5ad4138cda1dcc5798e2f40f61c484a04a91f9d7a351f3f583c72e56254bda9af8843b2a99aa451d1a8930
+EBUILD pytest-1.1.4.ebuild 498 BLAKE2B baff4400e53a36763028b567fd83186ff36670d36273c6ae80916c2cfff88e4661f684542a07cb057b22dd90fe4db7e8099e0e593cb2fdf32aac9fd44a2880cb SHA512 229083fb4672c3e068df4f48aaeb56ae34aeaba73565b29a03ca1722ba2f51cfae6b62af0af307a5540803e8cc7025fc6911c10a9102a1245e8a5b40eb828c95
+MISC metadata.xml 340 BLAKE2B c19b6303750b370db31319e743bdc49127368a5374b0d843dd433fc0e7b5582b41a2d4571356acb50d01a8a0b76d0fc267c47c740e1d221464914fe56781cd1c SHA512 5b3eb98fdc674b48cdf126bc027b5c9c09145e9020fb2b54788452e1329e64890fe78628dcf7098266b1ea72db038520959233e1ef89ce479eeab259ac31650c
diff --git a/app-vim/pytest/metadata.xml b/app-vim/pytest/metadata.xml
new file mode 100644
index 000000000000..6c8987e6f46f
--- /dev/null
+++ b/app-vim/pytest/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>monsieurp@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-vim/pytest/pytest-1.1.4.ebuild b/app-vim/pytest/pytest-1.1.4.ebuild
new file mode 100644
index 000000000000..f037f84ce118
--- /dev/null
+++ b/app-vim/pytest/pytest-1.1.4.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: run tests with py.test from within vim"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=3424"
+SRC_URI="https://www.vim.org/scripts/download_script.php?src_id=18178 -> ${P}.tar.gz"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="dev-python/pytest"
+
+S="${WORKDIR}/${PN}.vim"