summaryrefslogtreecommitdiff
path: root/app-vim/pydoc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/pydoc
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/pydoc')
-rw-r--r--app-vim/pydoc/Manifest3
-rw-r--r--app-vim/pydoc/metadata.xml14
-rw-r--r--app-vim/pydoc/pydoc-2.0-r1.ebuild24
3 files changed, 41 insertions, 0 deletions
diff --git a/app-vim/pydoc/Manifest b/app-vim/pydoc/Manifest
new file mode 100644
index 000000000000..38bfc6234c90
--- /dev/null
+++ b/app-vim/pydoc/Manifest
@@ -0,0 +1,3 @@
+DIST pydoc-2.0.tar.gz 2795 BLAKE2B d780265c474081431e43076db9e5bc244677d9deaaa44bbd6ba2c2bdce7e88b8e2f0c6a9e14ca5a3a4bda7925b5c5bc108a34d5d6fecaabe9f0a025774b101ca SHA512 bea2e0dcb82090803b45e0cbccf5ad610a39f22d04c099e5e946e2b3707c9cbd69b85e3f1024a73760d1ff81a0199aeeb3bab20546307676953156eff7185214
+EBUILD pydoc-2.0-r1.ebuild 633 BLAKE2B 8527539ebbeb627acaa4a88657d01f4930f15cd34af125ec63041f145f65f0d6d3a81e654a5badd64fe935baa32ad302acdfc3a4a0000bb036aeef7072355f39 SHA512 a5ba3b471425088e75d756248255a46d7a7216ca07dfc9fa147583ee4bfa36fae9968017eca5f7944260c4bcaed1a123e9771f48abae0aa850bd21aef6c23235
+MISC metadata.xml 424 BLAKE2B cd8fb601b39c8ff1247498a196bf776d70b0765661f866b355675b5d8ac76a713bf007b8aafa503d438ac7fb49295e6f09df9d4b1d9d7fc1cba323fd139eea12 SHA512 b64ab21cb93c8d24a87fc0434baac17c21ef9a4a23d4d2622d6c733a043d84aab2c3cb00acc41edd9c61e8599cfcfddeb50025ea0135f9f10c0f5ee243f61dab
diff --git a/app-vim/pydoc/metadata.xml b/app-vim/pydoc/metadata.xml
new file mode 100644
index 000000000000..2b82c379a010
--- /dev/null
+++ b/app-vim/pydoc/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>monsieurp@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">fs111/pydoc.vim</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/pydoc/pydoc-2.0-r1.ebuild b/app-vim/pydoc/pydoc-2.0-r1.ebuild
new file mode 100644
index 000000000000..775d576a1d3b
--- /dev/null
+++ b/app-vim/pydoc/pydoc-2.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit vim-plugin python-single-r1
+
+DESCRIPTION="vim plugin: integrates python documentation view and search tool"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=910 https://github.com/fs111/pydoc.vim"
+SRC_URI="https://github.com/fs111/${PN}.vim/tarball/${PV} -> ${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc ppc64 x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="app-arch/unzip"
+RDEPEND="${PYTHON_DEPS}"
+
+src_unpack() {
+ default
+ mv * "${P}" || die
+}