summaryrefslogtreecommitdiff
path: root/app-vim/pydoc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-vim/pydoc
reinit the tree, so we can have metadata
Diffstat (limited to 'app-vim/pydoc')
-rw-r--r--app-vim/pydoc/Manifest5
-rw-r--r--app-vim/pydoc/metadata.xml14
-rw-r--r--app-vim/pydoc/pydoc-2.0-r1.ebuild24
-rw-r--r--app-vim/pydoc/pydoc-2.0.ebuild21
4 files changed, 64 insertions, 0 deletions
diff --git a/app-vim/pydoc/Manifest b/app-vim/pydoc/Manifest
new file mode 100644
index 000000000000..7d6b9ba000b8
--- /dev/null
+++ b/app-vim/pydoc/Manifest
@@ -0,0 +1,5 @@
+DIST pydoc-2.0.tar.gz 2795 SHA256 3d55f46aeccc76b1f0c21fef7e859158929710f7255719eba996f532cb0ce0f9 SHA512 bea2e0dcb82090803b45e0cbccf5ad610a39f22d04c099e5e946e2b3707c9cbd69b85e3f1024a73760d1ff81a0199aeeb3bab20546307676953156eff7185214 WHIRLPOOL 7a0337a68ba7075c08c379e9bc138b1130cf4c7b56e529f11da98e5689a64a4d84afb155f1e8306a229725c1e61a619a94371f722c6ad7adae30dc9040aba7a3
+EBUILD pydoc-2.0-r1.ebuild 636 SHA256 f87cbb2c59e0f47b5efea0a1f085f8e07c779279c526f64308e38444f3f2e4e6 SHA512 26caaae3822c8a958bfcad05981652f1a6204e6a9c0256a4a977792f5b05fd27a4950750a0c973af80b70876c0db0ac0caf733d1b5430b24c2e36dff50c700e9 WHIRLPOOL dd04984d67b334f50733205f657c26da22b60fa5a487e8583c0ba003ae7fe0b5e9daec4e6e6c9ab58cfdf797004e2c03a1203aff700795787535d6fdbc55444d
+EBUILD pydoc-2.0.ebuild 542 SHA256 28a8a460ff03470b4d227ec821decb362dfeacb5674c232d839b4c83986faa6d SHA512 5f4866a1c36908510e02f9da44183db21c0a3c8824049d3e2cb1dcca9fddd69c05b117f5ef0710af3133535fe13549499414bbbc6554fe5a3d798903affcec98 WHIRLPOOL 7b5e49a031dfc93d10b029930f5a9f18fa69bb55ddcb77d212bcd355046e0a4e8e357d7f30c72edf7ecdbbc705d52beff3b62be5e87621cd266e7f11a952f8ba
+MISC ChangeLog 570 SHA256 b2f195079eafba306422b12c6eb903e50a4d9571607878735c120bb6fccbeec8 SHA512 7aa64aea9cecd489a28904b78998ad471a466e1aef2b955c8dadfff54c4150261ef094ddd82d8fe80bce66838144a92c8e926676565f2e562882608c6e5db3e5 WHIRLPOOL d5dae54fc62bceb4255fa16dc4ad0d2ece0acfd3f5efd83f963c6edf33ed280747a1b1d662cb503160246cf817b3f83002e2e5dc0eb64416d4b2f319fc2a98bd
+MISC metadata.xml 424 SHA256 25b4b474c67fb633cc2e943bb98af2b4eba25fdff26a9b5c7bf2872c43d24e31 SHA512 b64ab21cb93c8d24a87fc0434baac17c21ef9a4a23d4d2622d6c733a043d84aab2c3cb00acc41edd9c61e8599cfcfddeb50025ea0135f9f10c0f5ee243f61dab WHIRLPOOL 9b232a1a86b18b751353d2f4d25815a2df10fe1af36ba042a944129be6c3274d76a9e56f399c683011129a4ee02ff5fba9070842c1d1e414f2050b28257da994
diff --git a/app-vim/pydoc/metadata.xml b/app-vim/pydoc/metadata.xml
new file mode 100644
index 000000000000..2b82c379a010
--- /dev/null
+++ b/app-vim/pydoc/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>monsieurp@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">fs111/pydoc.vim</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/pydoc/pydoc-2.0-r1.ebuild b/app-vim/pydoc/pydoc-2.0-r1.ebuild
new file mode 100644
index 000000000000..7114a955e20b
--- /dev/null
+++ b/app-vim/pydoc/pydoc-2.0-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit vim-plugin python-single-r1
+
+DESCRIPTION="vim plugin: integrates python documentation view and search tool"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=910 https://github.com/fs111/pydoc.vim"
+SRC_URI="https://github.com/fs111/${PN}.vim/tarball/${PV} -> ${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="app-arch/unzip"
+RDEPEND="${PYTHON_DEPS}"
+
+src_unpack() {
+ default
+ mv * "${P}" || die
+}
diff --git a/app-vim/pydoc/pydoc-2.0.ebuild b/app-vim/pydoc/pydoc-2.0.ebuild
new file mode 100644
index 000000000000..ad9661d62975
--- /dev/null
+++ b/app-vim/pydoc/pydoc-2.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: integrates python documentation view and search tool"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=910 https://github.com/fs111/pydoc.vim"
+SRC_URI="https://github.com/fs111/${PN}.vim/tarball/${PV} -> ${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND="dev-lang/python:*"
+
+src_unpack() {
+ default
+ mv * "${P}" || die
+}