summaryrefslogtreecommitdiff
path: root/app-vim/pydiction/pydiction-1.2.3-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-20 19:52:06 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-20 19:52:06 +0000
commitd4d7098dcb2f9dd257109bbcb55fd40beda1b78d (patch)
tree48d3c6b3c45f18db0f90650f822ea19a10284f61 /app-vim/pydiction/pydiction-1.2.3-r2.ebuild
parent4161fa7d1be6dac96e36f8ed343f234a8ef3a74f (diff)
gentoo auto-resync : 20:12:2022 - 19:52:06
Diffstat (limited to 'app-vim/pydiction/pydiction-1.2.3-r2.ebuild')
-rw-r--r--app-vim/pydiction/pydiction-1.2.3-r2.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/app-vim/pydiction/pydiction-1.2.3-r2.ebuild b/app-vim/pydiction/pydiction-1.2.3-r2.ebuild
deleted file mode 100644
index aea6beb9b9f0..000000000000
--- a/app-vim/pydiction/pydiction-1.2.3-r2.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-inherit vim-plugin python-r1
-
-DESCRIPTION="vim plugin: tab-complete your Python code"
-HOMEPAGE="https://rkulla.github.io/pydiction/"
-SRC_URI="https://dev.gentoo.org/~monsieurp/packages/${P}.zip"
-S="${WORKDIR}/${PN}-master"
-
-LICENSE="vim"
-KEYWORDS="amd64 ppc ppc64 x86"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="app-arch/unzip"
-RDEPEND="${PYTHON_DEPS}"
-
-src_install() {
- # Rename pydiction script.
- mv "${PN}.py" "${PN}" || die
-
- # We're going to remove those files in a second
- # otherwise they're installed by Portage.
- local pyfiles=( complete-dict "${PN}" )
- insinto "/usr/share/${P}"
- doins complete-dict
-
- # pydiction is treated a singular script that lives on its own.
- python_foreach_impl python_doscript "${PN}"
- rm -v "${pyfiles[@]}" || die
-
- vim-plugin_src_install
-}