summaryrefslogtreecommitdiff
path: root/app-vim/pydiction/pydiction-1.2.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/pydiction/pydiction-1.2.3-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/pydiction/pydiction-1.2.3-r1.ebuild')
-rw-r--r--app-vim/pydiction/pydiction-1.2.3-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-vim/pydiction/pydiction-1.2.3-r1.ebuild b/app-vim/pydiction/pydiction-1.2.3-r1.ebuild
new file mode 100644
index 000000000000..0e9e20b9d9ba
--- /dev/null
+++ b/app-vim/pydiction/pydiction-1.2.3-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit vim-plugin python-r1
+
+DESCRIPTION="vim plugin: tab-complete your Python code"
+HOMEPAGE="https://rkulla.github.io/pydiction/"
+SRC_URI="https://dev.gentoo.org/~monsieurp/packages/${P}.zip"
+
+LICENSE="vim"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="app-arch/unzip"
+RDEPEND="${PYTHON_DEPS}"
+
+S="${WORKDIR}/${PN}-master"
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ local pyfiles=( complete-dict pydiction.py )
+ doins "${pyfiles[@]}"
+ rm -v "${pyfiles[@]}" || die
+ vim-plugin_src_install
+}