summaryrefslogtreecommitdiff
path: root/app-vim/pyclewn/pyclewn-2.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-10 21:05:55 +0000
commit71deace00d1a2b091313fe137ab7092418c6f87c (patch)
tree9f1f0dee23e13658e52f49437befe78427148c51 /app-vim/pyclewn/pyclewn-2.0.1.ebuild
parent29aabba0ea759c6a2864ff5631735b67ee38e5e0 (diff)
gentoo resync : 10.02.2020
Diffstat (limited to 'app-vim/pyclewn/pyclewn-2.0.1.ebuild')
-rw-r--r--app-vim/pyclewn/pyclewn-2.0.1.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/app-vim/pyclewn/pyclewn-2.0.1.ebuild b/app-vim/pyclewn/pyclewn-2.0.1.ebuild
deleted file mode 100644
index fb63112b6704..000000000000
--- a/app-vim/pyclewn/pyclewn-2.0.1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-inherit eutils vim-plugin distutils-r1
-
-SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
-
-DESCRIPTION="Pyclewn allows using vim as a front end to a debugger (pdb or gdb)"
-HOMEPAGE="http://pyclewn.sourceforge.net/"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-
-CDEPEND="|| (
- >=app-editors/vim-7.3[${PYTHON_USEDEP}]
- >=app-editors/gvim-7.3[netbeans,${PYTHON_USEDEP}]
-)"
-DEPEND="${CDEPEND}
- app-arch/vimball
-"
-RDEPEND="${DEPEND}
- $(python_gen_cond_dep \
- 'dev-python/trollius[${PYTHON_USEDEP}]' python{2_7,3_3})
-"
-
-SLOT="0"
-
-#Completely broken (runs vim), disable for now
-#python_test() {
-# esetup.py test
-#}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- vimball -x -C "${ED}"/usr/share/vim/vimfiles lib/clewn/runtime/${P}.vmb || die "Extracting vimball failed"
-}
-
-pkg_postinst() {
- vim-plugin_pkg_postinst
-
- optfeature "C/C++ debugging" sys-devel/gdb
- optfeature "Python debugging" dev-python/pdb-clone
-}