summaryrefslogtreecommitdiff
path: root/app-vim/omnicppcomplete
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/omnicppcomplete
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/omnicppcomplete')
-rw-r--r--app-vim/omnicppcomplete/Manifest3
-rw-r--r--app-vim/omnicppcomplete/metadata.xml8
-rw-r--r--app-vim/omnicppcomplete/omnicppcomplete-0.41.ebuild22
3 files changed, 33 insertions, 0 deletions
diff --git a/app-vim/omnicppcomplete/Manifest b/app-vim/omnicppcomplete/Manifest
new file mode 100644
index 000000000000..09b605154c88
--- /dev/null
+++ b/app-vim/omnicppcomplete/Manifest
@@ -0,0 +1,3 @@
+DIST omnicppcomplete-0.41.zip 38331 BLAKE2B bc85f1a90edbb837363a09d28db6c36842a90952f8965ee9005dff0aeea1e63bf68ff8ce37f09da36f245f3ef3aca36b9cbc5439d0c1c2c6c759fb0d4b276cfd SHA512 565703f0e21f818308dbfbfaaec981eb522621568dee5b021bb8fe243da464b1d7defa45dc1cc2ac3370b3b3c67fb39dcb0dd7a1535a4dfe2ad81218f4ac71f3
+EBUILD omnicppcomplete-0.41.ebuild 530 BLAKE2B 8ce6a1080d9d2cc6a43f1ff52ed775f8a630845cd0ab980c2518bcd2fa5eab50ec3feb7024f42013835c7cd666edf5cbb634c7c1654e0897379cad05774067f0 SHA512 6cdfc30ef7ef07e307e8e223f342009eb0e394745faa4d46b146c7f55de32ff4c977d6f6d675769cf23badf7ef8bb9f0eac5a0282a9d7de023774c067e0aa42e
+MISC metadata.xml 249 BLAKE2B 7ae6eac3ca23edbcbaa6aee682bb4aec155e3166f169eef8e4400e59fa56113ecc3593680d55cc57f08a4a718963dd3d0bb804bd1e8771ed60a4bebaae9db281 SHA512 4051dd059d975d2e1799125f7defbf5a62a168241d8b83d83710592efd60808800951c4fd6da1294044d7e7ec6b757b8d50593fd076696f826dec761e99645c7
diff --git a/app-vim/omnicppcomplete/metadata.xml b/app-vim/omnicppcomplete/metadata.xml
new file mode 100644
index 000000000000..5c000c763084
--- /dev/null
+++ b/app-vim/omnicppcomplete/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-vim/omnicppcomplete/omnicppcomplete-0.41.ebuild b/app-vim/omnicppcomplete/omnicppcomplete-0.41.ebuild
new file mode 100644
index 000000000000..31f04ffd5232
--- /dev/null
+++ b/app-vim/omnicppcomplete/omnicppcomplete-0.41.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIM_PLUGIN_VIM_VERSION="7.0"
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: C/C++ omni-completion with ctags database"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=1520"
+SRC_URI="https://www.vim.org/scripts/download_script.php?src_id=7722 -> ${P}.zip"
+
+LICENSE="vim.org"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=">=dev-util/ctags-5.7"
+
+S="${WORKDIR}"
+
+VIM_PLUGIN_HELPFILES="${PN}"