summaryrefslogtreecommitdiff
path: root/app-vim/notes
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/notes
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/notes')
-rw-r--r--app-vim/notes/Manifest3
-rw-r--r--app-vim/notes/metadata.xml11
-rw-r--r--app-vim/notes/notes-0.33.4.ebuild30
3 files changed, 44 insertions, 0 deletions
diff --git a/app-vim/notes/Manifest b/app-vim/notes/Manifest
new file mode 100644
index 000000000000..04ee974aa4b1
--- /dev/null
+++ b/app-vim/notes/Manifest
@@ -0,0 +1,3 @@
+DIST notes-0.33.4.tar.gz 239372 BLAKE2B f326c5d6adf25cce9261ac555541261750926c55f73d3a3f57885f7f03f9fae97e03f20882cb74f5fcd78b1ec06c2e0a5b1eb977aadf6a9771c679205a4a48e9 SHA512 7f2147e786582e69760c6d76d7144bc1fd0f8934ce6574184e16f463f5ca9c21e9e0fc87f88b56922b8195b26be7b0f99435cef773ccbc360077cf568b98b98a
+EBUILD notes-0.33.4.ebuild 688 BLAKE2B e222ddbabb1bc5791c7aad52f476d9cc19cf70c8cc25decce0d59e6ecf544d5593ae04ad3a732945012635f85dd00186639d8be399e1a062ca8eda0a6db24c67 SHA512 e643ca31ca9124cc94db3727999fe66189233c2ce3985d66b036fa9493e839da7e053b3deba489be3aecf42371f8825126f79463d414fb418d1cd1c0f54640bb
+MISC metadata.xml 339 BLAKE2B 7d1ee9c5de677bd78ad2a5e0bca15deb9dc48bbfa56c7da216d47c0924fdab4e28c9db8878177471d2d4a7504770cf0395fd03a786d807971d07b61c31d8d7bb SHA512 ebc2c6981c7bb2ad9c8281e69d29203e5700bd5b930ee17feb16e5f1f581eb164971bcfc5584eb639404d70e2f13a3b8c51f4514759798ecc47ee8ec4776bbd1
diff --git a/app-vim/notes/metadata.xml b/app-vim/notes/metadata.xml
new file mode 100644
index 000000000000..2e0c837525af
--- /dev/null
+++ b/app-vim/notes/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">xolox/vim-notes</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/notes/notes-0.33.4.ebuild b/app-vim/notes/notes-0.33.4.ebuild
new file mode 100644
index 000000000000..9006ecc51f8c
--- /dev/null
+++ b/app-vim/notes/notes-0.33.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit python-single-r1 vim-plugin
+
+DESCRIPTION="vim plugin: easy note taking in vim"
+HOMEPAGE="http://peterodding.com/code/vim/notes/"
+SRC_URI="https://github.com/xolox/vim-notes/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+KEYWORDS="amd64 x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=app-vim/vim-misc-1.17.6"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+S=${WORKDIR}/vim-${P}
+
+src_prepare() {
+ # remove unnecessary files
+ rm addon-info.json INSTALL.md README.md || die
+
+ python_fix_shebang .
+}