summaryrefslogtreecommitdiff
path: root/app-vim/merginal
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/merginal
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/merginal')
-rw-r--r--app-vim/merginal/Manifest6
-rw-r--r--app-vim/merginal/merginal-2.0.2.ebuild26
-rw-r--r--app-vim/merginal/merginal-2.1.0.ebuild31
-rw-r--r--app-vim/merginal/merginal-9999.ebuild31
-rw-r--r--app-vim/merginal/metadata.xml11
5 files changed, 105 insertions, 0 deletions
diff --git a/app-vim/merginal/Manifest b/app-vim/merginal/Manifest
new file mode 100644
index 000000000000..94d82ee04c23
--- /dev/null
+++ b/app-vim/merginal/Manifest
@@ -0,0 +1,6 @@
+DIST merginal-2.0.2.tar.gz 15048 BLAKE2B 0c69f383ccb076e49b1ffcd7e74944c30b0d5e61054d636873a6391b39e4da6f1613f0f0a43d79b986a4681e4e7bd27a37f872e21a0e3df4520355a646a0adcf SHA512 fd2162491e04afdcf9c81770a3082c035b32ecfd8808be035db64ba6ed4ed4076c692d067f261c093fe12b467e020bb7c6770deabecf72e6631e1248d569b721
+DIST merginal-2.1.0.tar.gz 13510 BLAKE2B c44f3873f36ee540e69f1cd87558e2601f944f430d15ae0e863adbba5383637ddbae2bee01cf1f7788f677a159da7870a83b909562813f8817d610e85f9d4a96 SHA512 3514c210a016d3446e73b7acc8a8a4cc2427e0133df81d7c644aaa1465e9c5945d3f46b7cac697f70cac990563e595305360991cdaa8244032167aea5f88eaed
+EBUILD merginal-2.0.2.ebuild 607 BLAKE2B 2428c2b690b515859198f6908e322c7e033162259b4e3cb5323a67df0c5f91541478d3d899f228b314fe71adb3766927092bf952faa23594108802e69dab9516 SHA512 74f35751efe11c57d54fd42ede098ff57f9736d76eea74cbc1ff047f0aa5a8a6ac37e91aef4079e4095ed60ec53c6caa493f8231c32a56d4142add3365f869be
+EBUILD merginal-2.1.0.ebuild 726 BLAKE2B 563099f5ecf0290cf8542523794ed261252dd979f006a5e65fb48e1abade837b66485d056681c2b2a849d1fdcb9c9f2c6f1cd8fa5cc7a1e564232fb73ffa7ab9 SHA512 0792f9864e98b518a3a5422e3d1803cb51921b12c60856553d97880aba8b75c95a9ee3f0906475c39461a6f3266e6df31e09c778f96d3ca7fce36670804d5895
+EBUILD merginal-9999.ebuild 726 BLAKE2B 563099f5ecf0290cf8542523794ed261252dd979f006a5e65fb48e1abade837b66485d056681c2b2a849d1fdcb9c9f2c6f1cd8fa5cc7a1e564232fb73ffa7ab9 SHA512 0792f9864e98b518a3a5422e3d1803cb51921b12c60856553d97880aba8b75c95a9ee3f0906475c39461a6f3266e6df31e09c778f96d3ca7fce36670804d5895
+MISC metadata.xml 345 BLAKE2B d484adbd45fa9339d6199f9978129adce0a8dc2ac1a8f0edf4dee62cd115a8043b0aadd6bc7708305516fd16caa6da8feeab3270f2e7f82bb751e916c0a2573e SHA512 c86f966d8b95d7ae380395af45af1046b3102e4c921f5a4102b4d421c707659b4e5aee25765b8af1e815cb5274963bdcae482cc4700d3196259e62ecaf6919ce
diff --git a/app-vim/merginal/merginal-2.0.2.ebuild b/app-vim/merginal/merginal-2.0.2.ebuild
new file mode 100644
index 000000000000..d74ee03f7bc0
--- /dev/null
+++ b/app-vim/merginal/merginal-2.0.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+MY_PN=vim-${PN}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="vim script: fugitive extension to manage and merge git branches"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=4955 https://github.com/idanarye/vim-merginal/"
+SRC_URI="https://github.com/idanarye/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="vim"
+KEYWORDS="amd64 x86"
+
+RDEPEND="app-vim/fugitive"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ rm README.md || die
+ default
+}
diff --git a/app-vim/merginal/merginal-2.1.0.ebuild b/app-vim/merginal/merginal-2.1.0.ebuild
new file mode 100644
index 000000000000..fbe6b96d4612
--- /dev/null
+++ b/app-vim/merginal/merginal-2.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+MY_PN=vim-${PN}
+MY_P=${MY_PN}-${PV}
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/idanarye/${MY_PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/idanarye/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="vim script: fugitive extension to manage and merge git branches"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=4955 https://github.com/idanarye/vim-merginal/"
+LICENSE="vim"
+
+RDEPEND="app-vim/fugitive"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+src_prepare() {
+ rm README.md || die
+ default
+}
diff --git a/app-vim/merginal/merginal-9999.ebuild b/app-vim/merginal/merginal-9999.ebuild
new file mode 100644
index 000000000000..fbe6b96d4612
--- /dev/null
+++ b/app-vim/merginal/merginal-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+MY_PN=vim-${PN}
+MY_P=${MY_PN}-${PV}
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/idanarye/${MY_PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/idanarye/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="vim script: fugitive extension to manage and merge git branches"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=4955 https://github.com/idanarye/vim-merginal/"
+LICENSE="vim"
+
+RDEPEND="app-vim/fugitive"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+src_prepare() {
+ rm README.md || die
+ default
+}
diff --git a/app-vim/merginal/metadata.xml b/app-vim/merginal/metadata.xml
new file mode 100644
index 000000000000..bd94d1ea0754
--- /dev/null
+++ b/app-vim/merginal/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">idanarye/vim-merginal</remote-id>
+ </upstream>
+</pkgmetadata>