summaryrefslogtreecommitdiff
path: root/app-vim/lustyexplorer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/lustyexplorer
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/lustyexplorer')
-rw-r--r--app-vim/lustyexplorer/Manifest5
-rw-r--r--app-vim/lustyexplorer/lustyexplorer-4.1.ebuild26
-rw-r--r--app-vim/lustyexplorer/lustyexplorer-4.3.ebuild26
-rw-r--r--app-vim/lustyexplorer/metadata.xml8
4 files changed, 65 insertions, 0 deletions
diff --git a/app-vim/lustyexplorer/Manifest b/app-vim/lustyexplorer/Manifest
new file mode 100644
index 000000000000..54d2f1d2e6c9
--- /dev/null
+++ b/app-vim/lustyexplorer/Manifest
@@ -0,0 +1,5 @@
+DIST lustyexplorer-4.1.tar.bz2 17098 BLAKE2B 6ede97cc83962d4bb95751a2a1a83c06178bc427e9ea2f10d4fcf235133b4ec2de5bc1f8fa8676bb555c0108be25b5e85f5ffd3351e8c6e3c6e81f021b22f091 SHA512 2f9af8c40f93333a4a734722a6ac6532fc05719165d730ac10bb0b3096a769a7a5fc2bb02fe0f457563b9ada69474265b1de6d5b3e2d9ca30503a704be496a86
+DIST lustyexplorer-4.3.tar.bz2 17373 BLAKE2B 643eb4c7573932fa63030766670d7c398e307b72e08e93e53e31b7f21086a80196c8d4d7811032b8b945306fcdc7d86d59eb6b48ce0b79f38e628d6b4bec7519 SHA512 24ffa1fe5c1698dfa6093c7cfed2f08540ce130258df5e8ec135356ecea4c1f607f11e643ab859f551e63ecbbf6fc8a615a9514e1d4798b752cc97146c29c661
+EBUILD lustyexplorer-4.1.ebuild 840 BLAKE2B a83cb9ad89137d7de6ee070a2002ee9e4b9e80f3dc8906574a04e6bde7099b5b66ffc1c49bb7fe3cb1010166a41776b8e22926b92a7d4f30cdf980be712328bd SHA512 7d0d188de896ad6be8e1f985c96dae0bb147c82500c3a7d7e839e2411adf4c9939723da829bc14dff30839a066980950b448c18945a577b4cb2e6aa4670e3a0f
+EBUILD lustyexplorer-4.3.ebuild 840 BLAKE2B a83cb9ad89137d7de6ee070a2002ee9e4b9e80f3dc8906574a04e6bde7099b5b66ffc1c49bb7fe3cb1010166a41776b8e22926b92a7d4f30cdf980be712328bd SHA512 7d0d188de896ad6be8e1f985c96dae0bb147c82500c3a7d7e839e2411adf4c9939723da829bc14dff30839a066980950b448c18945a577b4cb2e6aa4670e3a0f
+MISC metadata.xml 249 BLAKE2B 7ae6eac3ca23edbcbaa6aee682bb4aec155e3166f169eef8e4400e59fa56113ecc3593680d55cc57f08a4a718963dd3d0bb804bd1e8771ed60a4bebaae9db281 SHA512 4051dd059d975d2e1799125f7defbf5a62a168241d8b83d83710592efd60808800951c4fd6da1294044d7e7ec6b757b8d50593fd076696f826dec761e99645c7
diff --git a/app-vim/lustyexplorer/lustyexplorer-4.1.ebuild b/app-vim/lustyexplorer/lustyexplorer-4.1.ebuild
new file mode 100644
index 000000000000..563cf2c9e83d
--- /dev/null
+++ b/app-vim/lustyexplorer/lustyexplorer-4.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: dynamic filesystem and buffer explorer"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=1890"
+LICENSE="bufexplorer.vim"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="lusty-explorer.txt"
+
+RDEPEND="|| ( app-editors/vim[ruby] app-editors/gvim[ruby] )"
+
+src_prepare() {
+ # There's good documentation included with the script, but it's not
+ # in a helpfile. Since there's rather too much information to include
+ # in a VIM_PLUGIN_HELPTEXT, we'll sed ourselves a help doc.
+ mkdir "${S}"/doc
+ sed -e '0,/"$/d' -e '/" GetLatest.\+$/,9999d' -e 's/^" \?//' \
+ -e "s/\(Name Of File: \)\([^.]\+\)\.vim/\1*\2.txt*/" \
+ plugin/lusty-explorer.vim > doc/lusty-explorer.txt
+}
diff --git a/app-vim/lustyexplorer/lustyexplorer-4.3.ebuild b/app-vim/lustyexplorer/lustyexplorer-4.3.ebuild
new file mode 100644
index 000000000000..563cf2c9e83d
--- /dev/null
+++ b/app-vim/lustyexplorer/lustyexplorer-4.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: dynamic filesystem and buffer explorer"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=1890"
+LICENSE="bufexplorer.vim"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="lusty-explorer.txt"
+
+RDEPEND="|| ( app-editors/vim[ruby] app-editors/gvim[ruby] )"
+
+src_prepare() {
+ # There's good documentation included with the script, but it's not
+ # in a helpfile. Since there's rather too much information to include
+ # in a VIM_PLUGIN_HELPTEXT, we'll sed ourselves a help doc.
+ mkdir "${S}"/doc
+ sed -e '0,/"$/d' -e '/" GetLatest.\+$/,9999d' -e 's/^" \?//' \
+ -e "s/\(Name Of File: \)\([^.]\+\)\.vim/\1*\2.txt*/" \
+ plugin/lusty-explorer.vim > doc/lusty-explorer.txt
+}
diff --git a/app-vim/lustyexplorer/metadata.xml b/app-vim/lustyexplorer/metadata.xml
new file mode 100644
index 000000000000..5c000c763084
--- /dev/null
+++ b/app-vim/lustyexplorer/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+</pkgmetadata>