summaryrefslogtreecommitdiff
path: root/app-vim/lustyexplorer/lustyexplorer-4.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-19 11:37:34 +0000
commitb7b97785ebbb2f11d24d14dab8b81ed274f4ce6a (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /app-vim/lustyexplorer/lustyexplorer-4.3-r1.ebuild
parent066d27181e9a797ad9f8fc43b49fc9a10ff2f707 (diff)
gentoo resync : 19.03.2019
Diffstat (limited to 'app-vim/lustyexplorer/lustyexplorer-4.3-r1.ebuild')
-rw-r--r--app-vim/lustyexplorer/lustyexplorer-4.3-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-vim/lustyexplorer/lustyexplorer-4.3-r1.ebuild b/app-vim/lustyexplorer/lustyexplorer-4.3-r1.ebuild
new file mode 100644
index 000000000000..18e37c2dd2f7
--- /dev/null
+++ b/app-vim/lustyexplorer/lustyexplorer-4.3-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: dynamic filesystem and buffer explorer"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=1890"
+LICENSE="bufexplorer.vim"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="lusty-explorer.txt"
+
+RDEPEND="|| (
+ app-editors/vim[ruby]
+ app-editors/gvim[ruby]
+)"
+
+src_prepare() {
+ default
+
+ # There's good documentation included with the script, but it's not
+ # in a helpfile. Since there's rather too much information to include
+ # in a VIM_PLUGIN_HELPTEXT, we'll sed ourselves a help doc.
+ mkdir "${S}"/doc || die
+ sed -e '0,/"$/d' -e '/" GetLatest.\+$/,9999d' -e 's/^" \?//' \
+ -e "s/\(Name Of File: \)\([^.]\+\)\.vim/\1*\2.txt*/" \
+ plugin/lusty-explorer.vim > doc/lusty-explorer.txt
+}