summaryrefslogtreecommitdiff
path: root/app-vim/lustyexplorer/lustyexplorer-4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-vim/lustyexplorer/lustyexplorer-4.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-vim/lustyexplorer/lustyexplorer-4.1.ebuild')
-rw-r--r--app-vim/lustyexplorer/lustyexplorer-4.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-vim/lustyexplorer/lustyexplorer-4.1.ebuild b/app-vim/lustyexplorer/lustyexplorer-4.1.ebuild
new file mode 100644
index 000000000000..563cf2c9e83d
--- /dev/null
+++ b/app-vim/lustyexplorer/lustyexplorer-4.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: dynamic filesystem and buffer explorer"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=1890"
+LICENSE="bufexplorer.vim"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="lusty-explorer.txt"
+
+RDEPEND="|| ( app-editors/vim[ruby] app-editors/gvim[ruby] )"
+
+src_prepare() {
+ # There's good documentation included with the script, but it's not
+ # in a helpfile. Since there's rather too much information to include
+ # in a VIM_PLUGIN_HELPTEXT, we'll sed ourselves a help doc.
+ mkdir "${S}"/doc
+ sed -e '0,/"$/d' -e '/" GetLatest.\+$/,9999d' -e 's/^" \?//' \
+ -e "s/\(Name Of File: \)\([^.]\+\)\.vim/\1*\2.txt*/" \
+ plugin/lusty-explorer.vim > doc/lusty-explorer.txt
+}