summaryrefslogtreecommitdiff
path: root/app-vim/locateopen
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-15 04:49:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-15 04:49:10 +0100
commitefca79f216bfeffd55e7731fbf24126d093e1084 (patch)
treef19ba31d8686b3de4192db3e4c4dc9f3d9af54b5 /app-vim/locateopen
parentea7f3f690b55cdfa8b2d350b03c1dfc0c8357a51 (diff)
gentoo auto-resync : 15:09:2023 - 04:49:10
Diffstat (limited to 'app-vim/locateopen')
-rw-r--r--app-vim/locateopen/Manifest1
-rw-r--r--app-vim/locateopen/locateopen-1.3-r2.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/app-vim/locateopen/Manifest b/app-vim/locateopen/Manifest
index 14cf968c6b27..2f09128bee34 100644
--- a/app-vim/locateopen/Manifest
+++ b/app-vim/locateopen/Manifest
@@ -1,3 +1,4 @@
DIST locateopen-1.3.tar.bz2 1925 BLAKE2B fe9b4c7abc0fb26eaa75298368ae7b9440a2c6d7d25e94da80693de0f61517b50fb200536b488f485cfd3c4b243bb8abe5606dda12e07a8f6246bd644d74e8de SHA512 93d1f89eef3b877830a01a0fa609855108e3415836128d27f3b66fa6e3c57614a81e0cbcc984e39e0353883b7d8fec86c73f77a4c3f10a1cb8183b8be21a6dbe
EBUILD locateopen-1.3-r1.ebuild 788 BLAKE2B 90163c2322ed0faf7f13aea967fd75d7e2119736bbffb532702cb288f7929e1f9e4348321a6e3dee41b56176dfb91f200d283941788738a096f80b80c17632c5 SHA512 1335dea394142b2ebd472e7afd9cbc7f5faff1c5fa539d5b22053163136e0447ae8b9e8028aeb7d983bc48ca1ba66ccdda27e0ff697edc62e7fe9c6eee93b634
+EBUILD locateopen-1.3-r2.ebuild 770 BLAKE2B b59da416618a584a301e042e035f6a17546452bc826f4b2f2c620c664eeac09d5ca008a1692ccd74244e3ca904442b5a99b19c0b461364f4526c1e6a4d3dd6c8 SHA512 ed75cde620bc0f0c1a396204ee4e06d7d4582bd56edfdd689337ad70f0aa9701eb2e0ec1a28c04e97b86b1fe918274643e0be2170ea14dc6e782e359d2b244da
MISC metadata.xml 250 BLAKE2B 159edb6cbbe3884fd7b328cba2125da0a51b5c0be964e60b708efe1bd040a41abdf16f8dbcfaecb9e6e1073528ac99195a08d7045d433414ec2ba1c94d582761 SHA512 6c29f24b33b8829463103cee99e2cf65cf550aa1d6c60c5a746ca2947a97a052969c8dfb9d12ae8114db0971626f9246cb9e4808d951eeae78321325da1ac32a
diff --git a/app-vim/locateopen/locateopen-1.3-r2.ebuild b/app-vim/locateopen/locateopen-1.3-r2.ebuild
new file mode 100644
index 000000000000..620fa6113d63
--- /dev/null
+++ b/app-vim/locateopen/locateopen-1.3-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: open a file without supplying a path"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=858"
+
+LICENSE="vim"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+
+RDEPEND="sys-apps/mlocate"
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides commands that hook vim into mlocate:
+\ :LocateEdit filename
+\ :LocateSplit filename
+\ :LocateSource filename
+\ :LocateRead filename
+To configure:
+\ :let g:locateopen_ignorecase = 1 \" enable ignore case mode
+\ :let g:locateopen_smartcase = 0 \" disable smart case mode
+\ :let g:locateopen_alwaysprompt = 1 \" show menu for one match"