summaryrefslogtreecommitdiff
path: root/app-vim/info/info-1.7-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-vim/info/info-1.7-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-vim/info/info-1.7-r2.ebuild')
-rw-r--r--app-vim/info/info-1.7-r2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-vim/info/info-1.7-r2.ebuild b/app-vim/info/info-1.7-r2.ebuild
new file mode 100644
index 000000000000..fdc870f23c28
--- /dev/null
+++ b/app-vim/info/info-1.7-r2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: GNU info documentation browser"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=21"
+LICENSE="BSD"
+KEYWORDS="x86 alpha sparc ia64 ppc s390 amd64"
+IUSE=""
+
+VIM_PLUGIN_HELPTEXT="This plugin adds the :Info command."
+
+src_prepare() {
+ default
+
+ # The 'h' key is a bad choice for help. 'H' would have been a
+ # much better choice. I sent this suggestion to the maintainer,
+ # but no reply.
+ sed -i 's/\(noremap <buffer> \)h/\1H/' plugin/info.vim || die 'sed failed'
+}