summaryrefslogtreecommitdiff
path: root/app-vim/help-extra-syntax/help-extra-syntax-20050106-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /app-vim/help-extra-syntax/help-extra-syntax-20050106-r2.ebuild
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'app-vim/help-extra-syntax/help-extra-syntax-20050106-r2.ebuild')
-rw-r--r--app-vim/help-extra-syntax/help-extra-syntax-20050106-r2.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/app-vim/help-extra-syntax/help-extra-syntax-20050106-r2.ebuild b/app-vim/help-extra-syntax/help-extra-syntax-20050106-r2.ebuild
new file mode 100644
index 000000000000..bbe11531b29a
--- /dev/null
+++ b/app-vim/help-extra-syntax/help-extra-syntax-20050106-r2.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: extra syntax highlighting for help files"
+HOMEPAGE="http://www.drchip.org/astronaut/vim/"
+LICENSE="public-domain"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ~ppc ppc64 sparc x86"
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides additional syntax highlighting for help files."
+
+src_prepare() {
+ default
+ # use hi def link, bug #101797 / bug #101804
+ sed -i -e 's,^hi link,hi def link,' \
+ "after/syntax/help.vim.d/extra-help-syntax.vim" || die
+}