summaryrefslogtreecommitdiff
path: root/app-vim/haskellmode/haskellmode-20101118-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/haskellmode/haskellmode-20101118-r1.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/haskellmode/haskellmode-20101118-r1.ebuild')
-rw-r--r--app-vim/haskellmode/haskellmode-20101118-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-vim/haskellmode/haskellmode-20101118-r1.ebuild b/app-vim/haskellmode/haskellmode-20101118-r1.ebuild
new file mode 100644
index 000000000000..00f065cc2c85
--- /dev/null
+++ b/app-vim/haskellmode/haskellmode-20101118-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIM_PLUGIN_VIM_VERSION="7.1"
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Provides IDE-like features for Haskell development"
+HOMEPAGE="http://projects.haskell.org/haskellmode-vim"
+SRC_URI="http://code.haskell.org/~wwolff/haskellmode/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT=0
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ ${RDEPEND}"
+
+RDEPEND="
+ dev-lang/ghc[doc]
+ net-misc/wget"
+
+VIM_PLUGIN_HELPFILES="haskellmode"
+VIM_PLUGIN_MESSAGES="filetype"
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ elog "You must set 'g:haddock_browser' to the path of your preferred browser, and"
+ elog "depending on your setup you may also want to change the default value of"
+ elog "'g:haddock_browser_callformat' (see ':help g:haddock_browser_callformat' for"
+ elog "full usage info). You can persist these settings in your vimrc file, for"
+ elog "example:"
+ elog
+ elog " let g:haddock_browser=\"/usr/bin/elinks\""
+ elog " let g:haddock_browser_callformat=\"%s file://%s >/dev/null 2>&1 &\""
+ elog
+ elog "To enable GHC compiler integration, also add the following to your vimrc:"
+ elog
+ elog " au BufEnter *.hs compiler ghc"
+ elog
+ elog "The first time you load haskellmode, you must generate a Haddock index. Do"
+ elog "this with the command:"
+ elog
+ elog " :ExportDocIndex"
+ elog
+ elog "Consult ${HOMEPAGE} for further setup and usage information."
+}