summaryrefslogtreecommitdiff
path: root/app-vim/gnupg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/gnupg
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/gnupg')
-rw-r--r--app-vim/gnupg/Manifest3
-rw-r--r--app-vim/gnupg/gnupg-2.6.ebuild28
-rw-r--r--app-vim/gnupg/metadata.xml8
3 files changed, 39 insertions, 0 deletions
diff --git a/app-vim/gnupg/Manifest b/app-vim/gnupg/Manifest
new file mode 100644
index 000000000000..57635c8c8bd9
--- /dev/null
+++ b/app-vim/gnupg/Manifest
@@ -0,0 +1,3 @@
+DIST gnupg-2.6.tar.bz2 12074 BLAKE2B d06e4637627187e1d276c3b485e22b35f0cba78a491d34f0884da7ad320f12a3443e40a7c0e7e3f27be03984380eb966d593a283d768bb834a1fefed05656dd3 SHA512 1b7307954aad751006286edebb80767951b9bd9a8eff4c4a57fa6030cb442ceca12730a82c76a2181e1da19cc4cc8be21ccd4f8a21817aedf42785d8ff4b61ac
+EBUILD gnupg-2.6.ebuild 771 BLAKE2B f3767681669d829f63e517e3919e5921c8903f231dc7138470cab808c2d82ba7a5681ad8210d0cb279af7e33bda6ad227792a9d8c24ceaf1e9172ad6b1f227f5 SHA512 16533f194b0f5f78afaf278f4722317c71cace8db2982d6d759070b079ed72c73ebaaaa38d6654b272328c9b4281a02b1ffa100262e1c6aaff457896a67e06f2
+MISC metadata.xml 249 BLAKE2B 7ae6eac3ca23edbcbaa6aee682bb4aec155e3166f169eef8e4400e59fa56113ecc3593680d55cc57f08a4a718963dd3d0bb804bd1e8771ed60a4bebaae9db281 SHA512 4051dd059d975d2e1799125f7defbf5a62a168241d8b83d83710592efd60808800951c4fd6da1294044d7e7ec6b757b8d50593fd076696f826dec761e99645c7
diff --git a/app-vim/gnupg/gnupg-2.6.ebuild b/app-vim/gnupg/gnupg-2.6.ebuild
new file mode 100644
index 000000000000..ef344bdcf3f9
--- /dev/null
+++ b/app-vim/gnupg/gnupg-2.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="transparent editing of gpg encrypted files"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=3645"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ~arm x86"
+
+RDEPEND="app-crypt/gnupg"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ default
+
+ # There's good documentation included with the script, but it's not
+ # in a helpfile. Since there's rather too much information to include
+ # in a VIM_PLUGIN_HELPTEXT, we'll sed ourselves a help doc.
+ mkdir doc || die
+ sed -e '/" Section: Plugin header.\+$/,9999d' -e 's/^" \?//' \
+ -e 's/\(Name:\s\+\)\([^.]\+\)\.vim/\1*\2.txt*/' \
+ plugin/${PN}.vim \
+ > doc/${PN}.txt || die
+}
diff --git a/app-vim/gnupg/metadata.xml b/app-vim/gnupg/metadata.xml
new file mode 100644
index 000000000000..5c000c763084
--- /dev/null
+++ b/app-vim/gnupg/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+</pkgmetadata>