summaryrefslogtreecommitdiff
path: root/app-vim/gitlog/gitlog-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-vim/gitlog/gitlog-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-vim/gitlog/gitlog-9999.ebuild')
-rw-r--r--app-vim/gitlog/gitlog-9999.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/app-vim/gitlog/gitlog-9999.ebuild b/app-vim/gitlog/gitlog-9999.ebuild
new file mode 100644
index 000000000000..df4052666bdb
--- /dev/null
+++ b/app-vim/gitlog/gitlog-9999.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/PAntoine/vimgitlog.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/PAntoine/vimgitlog/archive/version_${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S=${WORKDIR}/vim${PN}-version_${PV}
+fi
+
+DESCRIPTION="vim plugin: git log and diff plugin for vim"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=4294 https://github.com/PAntoine/vimgitlog/"
+LICENSE="Artistic"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"