summaryrefslogtreecommitdiff
path: root/app-vim/gist
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-15 04:49:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-15 04:49:10 +0100
commitefca79f216bfeffd55e7731fbf24126d093e1084 (patch)
treef19ba31d8686b3de4192db3e4c4dc9f3d9af54b5 /app-vim/gist
parentea7f3f690b55cdfa8b2d350b03c1dfc0c8357a51 (diff)
gentoo auto-resync : 15:09:2023 - 04:49:10
Diffstat (limited to 'app-vim/gist')
-rw-r--r--app-vim/gist/Manifest3
-rw-r--r--app-vim/gist/gist-7.3-r1.ebuild28
-rw-r--r--app-vim/gist/gist-7.3.ebuild4
3 files changed, 32 insertions, 3 deletions
diff --git a/app-vim/gist/Manifest b/app-vim/gist/Manifest
index d48a591ab641..35da83377ffb 100644
--- a/app-vim/gist/Manifest
+++ b/app-vim/gist/Manifest
@@ -1,3 +1,4 @@
DIST gist-7.3.tar.gz 18170 BLAKE2B a6f281f92944203c17037a8ab9cd7e202ad491a11f7e79cf89794bfd94f188ac056c25c138fa98a9d50ebb38223e679b334c79705bf1d063e54f43297db6da40 SHA512 dbd3f638a365c8ee419140d9a934dd2c80fed181910137f61cec3c2d8d61300c21cabc9fdf85d83caa185cf78edb92990e04d49d937cd3fc546b6ae889e5cbb8
-EBUILD gist-7.3.ebuild 592 BLAKE2B 9ef115f51c72a14dc37b59550cef1830412b305bf90738d4ffdee98a0b3df13a461c8dc6b6a4504f4610454ed16e470382f5ced4586892fa4f6524487615ba1b SHA512 457e415760b8152a7feaa385b48344820648cc90cb8b2b9ce8857e247b5ecb34660e3f8469c0d7c17352d601d547c3995c027374aa28cebf3bc6a3726a4967b0
+EBUILD gist-7.3-r1.ebuild 601 BLAKE2B cfc4d0ea1575c856f664422ed79b4bbae1e30bb003bec352d18b3e6c68a39cff3e00862a14caa1afef69503a42957c878bd54813dc854b6f98769bbc2bf9aa82 SHA512 22bbbfe4a1313cccdb036e52e7b3ef1b4849e4646d204cab375baf58750b81a533011d7c0345cbcdb83c1ca5d0dc080dfa4f621792b16b08aa33ed5a2b451879
+EBUILD gist-7.3.ebuild 592 BLAKE2B 9e78b6a346b20b8e903f2ce6bb782a2a19e686a37c9b90d3735c634c6efd605763b61699f04b03d648ae10e07e87f18416b2c56b81ea5bb9d5f21743c27cf6a3 SHA512 c51310701a98482a34f5eeb11c3d5cd01fbd899fe9925cf656b6ab233551f8942ff1faf97611b5bfd3fc48748ea45b37d0e012518a2ce340fcb57b8c72823f0f
MISC metadata.xml 329 BLAKE2B 3adfb9fe58d4dddc733866aeec7969910555328e9a23342b4ad0457405948a83cad44cf856a3a6a303e089e6e784dd38285abba002906ee5057af757159b15ee SHA512 d4f0f838ab90bef7c9178f65d45f4f9d97f0d4c8feb7af29dd70bc2c19af370130d5003ffcf7c4450b4172b4189a58c0645cf5953fc05e5f6bc91951ba59d141
diff --git a/app-vim/gist/gist-7.3-r1.ebuild b/app-vim/gist/gist-7.3-r1.ebuild
new file mode 100644
index 000000000000..73379f7be49d
--- /dev/null
+++ b/app-vim/gist/gist-7.3-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+MY_PN="gist-vim"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="vim plugin: interact with gists (gist.github.com)"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=2423
+ https://github.com/mattn/vim-gist"
+SRC_URI="https://github.com/mattn/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+
+RDEPEND="
+ app-vim/webapi
+ net-misc/curl
+ dev-vcs/git
+"
+
+VIM_PLUGIN_HELPFILES="Gist.vim"
+
+src_compile() { :; }
diff --git a/app-vim/gist/gist-7.3.ebuild b/app-vim/gist/gist-7.3.ebuild
index 64f66578feae..7581070f2196 100644
--- a/app-vim/gist/gist-7.3.ebuild
+++ b/app-vim/gist/gist-7.3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -9,7 +9,7 @@ MY_PN=gist-vim
MY_P=${MY_PN}-${PV}
DESCRIPTION="vim plugin: interact with gists (gist.github.com)"
-HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=2423 https://github.com/mattn/gist-vim"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=2423 https://github.com/mattn/vim-gist"
SRC_URI="https://github.com/mattn/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
KEYWORDS="amd64 x86 ~x64-macos"