summaryrefslogtreecommitdiff
path: root/app-vim/gist
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/gist
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/gist')
-rw-r--r--app-vim/gist/Manifest3
-rw-r--r--app-vim/gist/gist-7.3.ebuild30
-rw-r--r--app-vim/gist/metadata.xml11
3 files changed, 44 insertions, 0 deletions
diff --git a/app-vim/gist/Manifest b/app-vim/gist/Manifest
new file mode 100644
index 000000000000..b946d69f43b7
--- /dev/null
+++ b/app-vim/gist/Manifest
@@ -0,0 +1,3 @@
+DIST gist-7.3.tar.gz 18170 BLAKE2B a6f281f92944203c17037a8ab9cd7e202ad491a11f7e79cf89794bfd94f188ac056c25c138fa98a9d50ebb38223e679b334c79705bf1d063e54f43297db6da40 SHA512 dbd3f638a365c8ee419140d9a934dd2c80fed181910137f61cec3c2d8d61300c21cabc9fdf85d83caa185cf78edb92990e04d49d937cd3fc546b6ae889e5cbb8
+EBUILD gist-7.3.ebuild 641 BLAKE2B 3a103330e9b8a0db424906590d6b2a076f44c9199b486aa482ced1aa473edc5df2effcdbcec9011767828487b07cbc524011e6038d02b74c68c78eacf62d4cac SHA512 bc96c7a8618ad4fd0226c0305187e6f4a1c99f39a63a4e62a50c482bffec89c863c6f4b0c7ab811f75d551d9431a5ebb43bd380894a4951c467054df132161d3
+MISC metadata.xml 328 BLAKE2B d72cba480fcc4b318e2ef5c42f25219aca6b08839b2f52945faf878abecdbb5a04dabd43612c39b48e3c9d24bb154831ad3866e4c187a0c2d7745a642d3f41aa SHA512 c7ecce29dc9fd9a7eaa2ebf61fbb0a191e3309ca87b4473d4aab058ee585287e7f7fbcaee931dda26807ff66fdb7a2b449edf9caf97ac616fcd283f34f24d710
diff --git a/app-vim/gist/gist-7.3.ebuild b/app-vim/gist/gist-7.3.ebuild
new file mode 100644
index 000000000000..adce6ea8f64d
--- /dev/null
+++ b/app-vim/gist/gist-7.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+MY_PN=gist-vim
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="vim plugin: interact with gists (gist.github.com)"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=2423 https://github.com/mattn/gist-vim"
+SRC_URI="https://github.com/mattn/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+KEYWORDS="amd64 x86 ~x64-macos"
+
+RDEPEND="
+ app-vim/webapi
+ net-misc/curl
+ dev-vcs/git
+"
+
+VIM_PLUGIN_HELPFILES="Gist.vim"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ default
+ rm README.md gist.vim* Makefile || die
+}
diff --git a/app-vim/gist/metadata.xml b/app-vim/gist/metadata.xml
new file mode 100644
index 000000000000..fe9c0bc2d0a3
--- /dev/null
+++ b/app-vim/gist/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mattn/gist-vim</remote-id>
+ </upstream>
+</pkgmetadata>