summaryrefslogtreecommitdiff
path: root/app-vim/gentoo-syntax
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /app-vim/gentoo-syntax
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'app-vim/gentoo-syntax')
-rw-r--r--app-vim/gentoo-syntax/Manifest2
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-20201007.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/app-vim/gentoo-syntax/Manifest b/app-vim/gentoo-syntax/Manifest
index 27ee6e2e76f6..5e4623d3c516 100644
--- a/app-vim/gentoo-syntax/Manifest
+++ b/app-vim/gentoo-syntax/Manifest
@@ -1,4 +1,6 @@
DIST gentoo-syntax-20200120.tar.bz2 18593 BLAKE2B c29dd3b3896bdb78e5c07b40474434c5ba6fa8b3a89f8ec237136d0474e8eaace8a72c7e3974ff63eaa24d3e57a1e61785bfc7889a93f7263ef9387caa651936 SHA512 ab57707b4a44f33c085a39eb745ca206312d84ca49680e24a462eb75d65cc37694a545f4a31b4ee2919d0f6b30276ce25f6caa7e20782511c7534bf2319e8a4f
+DIST gentoo-syntax-20201007.tar.bz2 18645 BLAKE2B 5ec28f03dde8d0be7dc24b337fabc02b0fbd53f4a97e4f22b9d042c0d3631f1be3a1e6e7d270b39e43688eb414f04525014acc3ac6e450dc9737341471fc15a7 SHA512 7b5554fdc68616177c906f6185c7c0843a75aac14ed28516d86ab7a37f67c5934e84c15b88c23e39c34665c1a3bb43deeff53e09ec665a4b4822309f77110ca9
EBUILD gentoo-syntax-20200120.ebuild 1268 BLAKE2B 17f1fcdb03331841097b2a5b7fddff0a8eabff9f95e7fb1e0605887e6a4257757b1cb657085f8cd396ee7a1694177a9cd32899f1944f4786f423d840c42d0e9f SHA512 a3366af4ff69b7e46312c9326ff238c47ae7bc83433d6189bfe17f8e91685604d43154caf343db21b9541c1f49291feb6497fad4ba28f42d91eb5180dcb6fa98
+EBUILD gentoo-syntax-20201007.ebuild 1276 BLAKE2B 7fedf5d7d85ce73923da1974b4e6ea6b7b09f060146e44357acb38f3b1ec0500c081546759b19a5f9f5ca74acf29b2487e37175c2cc7c603a81ee4cb11c153e3 SHA512 990d9dbe0b21ab506676ee36a65f49590a5a804f4e48a17056f904a3c6f343828ead9f5b314b35f374e01fd039d24564f5258335f97bccdd12fdb67d8479d0e9
EBUILD gentoo-syntax-99999999.ebuild 1087 BLAKE2B 9b7c64f1ec0215aa53e39c0c4db8352c47b19ee89a894dc95ef4a867415337ff901befaadf2ce468804e4167410c1d034002ca476c90925096875b3dc27b8868 SHA512 5f0e991bcc491e807ea86d89c47dcc8d6879c35d0f42d191a4e2cd4d40f117022e70cfb92503184e638273daed9780363066d07667c138592be1e1b6f4435b99
MISC metadata.xml 585 BLAKE2B 7f904a47ab12627ae911fa96328c50af2cb16b785fa0b60cace8a586b17de344625b749b52ef6b89b4751aba74bc25339b3e6c9105ee47d15b5c6539b5d902ee SHA512 dfed3c4c2b3697b00896591dc4b23eb6433ce77b4aaaab05119ca0b11e355e321b2cf5f0ab5e0b2dd075abd1a266908e07b80846a11d50f17155d7ab35e6c742
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-20201007.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-20201007.ebuild
new file mode 100644
index 000000000000..4651f7723a99
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-20201007.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Gentoo and Portage syntax highlighting"
+HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
+SRC_URI="https://gitweb.gentoo.org/proj/gentoo-syntax.git/snapshot/${P}.tar.bz2"
+
+LICENSE="vim"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="ignore-glep31"
+
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ default
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ fi
+ fi
+}