summaryrefslogtreecommitdiff
path: root/app-vim/gentoo-syntax
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-04 21:03:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-04 21:03:51 +0000
commitc4d92ab721dfc646b4a58429d965e9446294ce26 (patch)
tree8c0c331362f99c256c191229ac424b1cc8698005 /app-vim/gentoo-syntax
parent5565fb7867ee9faddf046e42a0a3a1a207803938 (diff)
gentoo auto-resync : 04:12:2022 - 21:03:51
Diffstat (limited to 'app-vim/gentoo-syntax')
-rw-r--r--app-vim/gentoo-syntax/Manifest2
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-4.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/app-vim/gentoo-syntax/Manifest b/app-vim/gentoo-syntax/Manifest
index dc5da589c807..c128964d6c24 100644
--- a/app-vim/gentoo-syntax/Manifest
+++ b/app-vim/gentoo-syntax/Manifest
@@ -1,4 +1,6 @@
DIST gentoo-syntax-2.tar.bz2 20302 BLAKE2B fa15fe5e8ef547dfa402b1742df3d6d38231528bcf6c6836e4d31e81ec2bce55ffa8c10400823c97688304f9dc6324ed3d257939c3077eb29a2fc3c191295604 SHA512 30e8e374382dc736febd1ee8031a7ccc14dfc61feade1815e3366988658189ac8670ff26532436ae608ff66c828e2de7327d0b39db37967206bcd9f418d26ea2
+DIST gentoo-syntax-4.tar.bz2 20344 BLAKE2B 3e9b75c1e9e395e04547a95bb6abd17e7404389ccc5a47d9cf9ca2973a55666ce17607c72fbd15a9b167033bf0f7d1447817b9346d56e2ddbd48c2acbdfdcffa SHA512 4aec2c40c4f582f697cc11ac73fe9301ce25bb38f240cc3c9e426247a4bd38fb83aa05407b65ac68313793735eafc71a3b1b55e0db4301941afe7c720a51bc85
EBUILD gentoo-syntax-2.ebuild 1244 BLAKE2B d3323a83eaedeac16e45db4bc56cb46d9529f7ddffa017ce60148f04e429b7a35d9a04fb6c55ea65f1ea01acc35083f6fdfd368f24b4fbcb2ad2410b3f65b25c SHA512 194c7f2f98ea57f157b7318318d2ae5129ac0d4d3b1a4de2b10aeaa48e4658297db00416108faf2b7460b520afcb2b67cda4303a2f48829c09c18d85803ab1ac
+EBUILD gentoo-syntax-4.ebuild 1252 BLAKE2B efe97f349f322617777896e67c35834a3903c7476a2418a7c48301b6b059e27e8a16774654236f4939e2e193581d6972cb67ec32027ef7c4377eb368d94037a0 SHA512 31708b68942f1ee7c38960c34ebe0601799147632a5dd38645cffa8c2c13c715814f276bfbdc86efe6b0fe34c7f7655037df87ef4651fe95b90b475f1c9afb2b
EBUILD gentoo-syntax-9999.ebuild 1084 BLAKE2B 5e2edf4d1eddb74486a7ef6c8025a2874591d90d0ff1bb5077781f3c66d43bfbebf0421561a7c730e1baff613776c0962c907aec502a6627d8361034b28e1bf3 SHA512 4af267e60fcf53b736c41232cb44241d2181afd3b38516a6e4a7a7b7ea83db10a4fec7272b362847bf773296f348a2b08503ce757886a14ff08a215ba5341194
MISC metadata.xml 586 BLAKE2B 9425e6a21617f806a0232c7f0ff75f148dc6855679236c9c2b88270db48161d3bffcb32066b372dc6af9cbac594f9d9dce6447d03fc675c151e75982f86ba598 SHA512 cb343dede228edd5c51dc2b2f6b8a1f09e4847365284218d5eb0c23c675f32fe4ab5025c6671f1dafbb63a87b83763a9caf97b04945329c32a1898123149d04b
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-4.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-4.ebuild
new file mode 100644
index 000000000000..6a2bb2bc0937
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Gentoo and Portage syntax highlighting"
+HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
+SRC_URI="https://gitweb.gentoo.org/proj/gentoo-syntax.git/snapshot/${P}.tar.bz2"
+
+LICENSE="vim"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="ignore-glep31"
+
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ default
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ fi
+ fi
+}