summaryrefslogtreecommitdiff
path: root/app-vim/gentoo-syntax
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/gentoo-syntax
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/gentoo-syntax')
-rw-r--r--app-vim/gentoo-syntax/Manifest6
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-20160530.ebuild53
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-20170225.ebuild53
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-99999999.ebuild53
-rw-r--r--app-vim/gentoo-syntax/metadata.xml14
5 files changed, 179 insertions, 0 deletions
diff --git a/app-vim/gentoo-syntax/Manifest b/app-vim/gentoo-syntax/Manifest
new file mode 100644
index 000000000000..9c88fea174d9
--- /dev/null
+++ b/app-vim/gentoo-syntax/Manifest
@@ -0,0 +1,6 @@
+DIST gentoo-syntax-20160530.tar.gz 18950 BLAKE2B 0e769cb4d67ebf1b4299a1aa0dc1bc1ce942a9e6b4f3528b5499ff83ffe9d165697576901c5ba9cca52de6e26abd0298f1f7a5383cdc0c8ca1dff0de2945080c SHA512 38881c5f16499eb053eb7a5514f6324b2a161f1392a044db0bbaf0cb71a0f17e1edebd4a685ff856a78525fbcb8c6267daa2503cfbc6f94d841cf3f6a25045bd
+DIST gentoo-syntax-20170225.tar.gz 18939 BLAKE2B 7586b45791e74e69ad6e0607bc0a4d52eba4747a6c4d9933d43db1196ceb57ac6317279c9e86f77c71bdb7379828dd96fe6d63a2933a3660f1639faf1b6df5d5 SHA512 2c01577910eccd413b85c094dbd12bf8445e2f560be1fffc4a4c3130b32587f9c298d8442b5cf12bd7d2950ab8c9e5b95a72f2f41c42c6dc939ffa2c26fd71d5
+EBUILD gentoo-syntax-20160530.ebuild 1808 BLAKE2B af7306c5b7ad151ef2da28bac70168ba6a2b0dd943fec7566b9392517ec04a851b5aa0fbea0c3cb355e9d2a79dbea352fa01d31cc8291db7a7bde5ff9a206387 SHA512 24f5f1a13094fa7afbad40c681270f867c6e9459b3558ed27c26a2664ba59f71b6f3dc34e142553f028cf1735577e6bdac6aecb030661af51faea237f2316e91
+EBUILD gentoo-syntax-20170225.ebuild 1823 BLAKE2B 1798286c3791945b838adab32855a01ad592e60d6f295d8dd31c2c95549651e17fc262bbe3f9c8d00480b6c0537a116fd26b70ae042c56983f845d64785b92e5 SHA512 1c6aa3f277c45d217d14347b32b44c14ccc3cdbea89ed8383177c51682cc2ce057f58d4f89406ee7b0289799df456575562031006110ea788523f6244dd9398e
+EBUILD gentoo-syntax-99999999.ebuild 1821 BLAKE2B 053b56d56693edde23a99b4f6fe0cd557b3bea9eba17523973a03e44f688ce17de67b5b76bd02756e6c156d48581af4e030056ed9088c0924c863e5692a6d364 SHA512 e56de9ddd61e1ac75b1f0c74da57689d999b93a30394dcfaf178ae90e59040298b4d8f9b31d7937ede740fde798aadac324912613602dafd8f20e9706a471fb5
+MISC metadata.xml 446 BLAKE2B 63902fa0fb1552a989ee9d53d36b535802ac65b468be2b74c472ae655107ca9de2695c1dd51ec98ebecda9c437caf32892560792d399a26c3814f0208212e7cc SHA512 2dc59075bad043ed183529af7484ab54e718774c275ce38e3b96af6b0461b8cf8d704dbcf37cb4aa7fb9dce2db3eb62075ff984ad7ac11fedf3f0bd2a582635c
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-20160530.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-20160530.ebuild
new file mode 100644
index 000000000000..8d1a5d52296a
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-20160530.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+if [[ ${PV} == 9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/gentoo/gentoo-syntax.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/gentoo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="vim plugin: Gentoo and Portage syntax highlighting"
+HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
+LICENSE="vim"
+IUSE="ignore-glep31"
+
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ default
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ else
+ elog "Note for developers and anyone else who edits ebuilds:"
+ elog " This release of gentoo-syntax now contains filetype rules to set"
+ elog " fileencoding for ebuilds and ChangeLogs to utf-8 as per GLEP 31."
+ elog " If you find this feature breaks things, please submit a bug and"
+ elog " assign it to vim@gentoo.org. You can use the 'ignore-glep31' USE"
+ elog " flag to remove these rules."
+ fi
+ fi
+}
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-20170225.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-20170225.ebuild
new file mode 100644
index 000000000000..e8e229270960
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-20170225.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+if [[ ${PV} == 9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/gentoo/gentoo-syntax.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/gentoo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="vim plugin: Gentoo and Portage syntax highlighting"
+HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
+LICENSE="vim"
+IUSE="ignore-glep31"
+
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ default
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ else
+ elog "Note for developers and anyone else who edits ebuilds:"
+ elog " This release of gentoo-syntax now contains filetype rules to set"
+ elog " fileencoding for ebuilds and ChangeLogs to utf-8 as per GLEP 31."
+ elog " If you find this feature breaks things, please submit a bug and"
+ elog " assign it to vim@gentoo.org. You can use the 'ignore-glep31' USE"
+ elog " flag to remove these rules."
+ fi
+ fi
+}
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-99999999.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-99999999.ebuild
new file mode 100644
index 000000000000..1e9dad4bb4e4
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-99999999.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+if [[ ${PV} == 9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/gentoo/gentoo-syntax.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/gentoo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="vim plugin: Gentoo and Portage syntax highlighting"
+HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
+LICENSE="vim"
+IUSE="ignore-glep31"
+
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ default
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ else
+ elog "Note for developers and anyone else who edits ebuilds:"
+ elog " This release of gentoo-syntax now contains filetype rules to set"
+ elog " fileencoding for ebuilds and ChangeLogs to utf-8 as per GLEP 31."
+ elog " If you find this feature breaks things, please submit a bug and"
+ elog " assign it to vim@gentoo.org. You can use the 'ignore-glep31' USE"
+ elog " flag to remove these rules."
+ fi
+ fi
+}
diff --git a/app-vim/gentoo-syntax/metadata.xml b/app-vim/gentoo-syntax/metadata.xml
new file mode 100644
index 000000000000..374f1cd98d23
--- /dev/null
+++ b/app-vim/gentoo-syntax/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <use>
+ <flag name="ignore-glep31">Remove GLEP 31 (UTF-8 file encodings) settings</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">gentoo/gentoo-syntax</remote-id>
+ </upstream>
+</pkgmetadata>