summaryrefslogtreecommitdiff
path: root/app-vim/gentoo-syntax
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /app-vim/gentoo-syntax
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'app-vim/gentoo-syntax')
-rw-r--r--app-vim/gentoo-syntax/Manifest2
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-20191127.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/app-vim/gentoo-syntax/Manifest b/app-vim/gentoo-syntax/Manifest
index da4b62d6c44f..9bef23d1f31f 100644
--- a/app-vim/gentoo-syntax/Manifest
+++ b/app-vim/gentoo-syntax/Manifest
@@ -1,4 +1,6 @@
DIST gentoo-syntax-20190609.tar.bz2 18401 BLAKE2B db738540fc85d8edd0269ade33e174db08b9231237f1138da9a3f6ecff7c188a041b312975629be652a5384d0c914ad8d7a3ac5ef14670e4bc0859fbdf3dcbc7 SHA512 70fbf6e37eee2e5b007eb59b76492f41046884a8310a6074ca5fbab666ec74d46ab3e57bbf2ae784db2e17bfd1c4801b18b71cf37f746e02ff640de1f6821ec7
+DIST gentoo-syntax-20191127.tar.bz2 18635 BLAKE2B 79db829602df5795e32c44db71e28cfcda06ef014e9d5e5cf47d6f7fcb0b054c46caef1bb594c4fceae318df8a8cd0c6a619771ae5438eb21deed530842ce53d SHA512 654b69cf55719b9c254c376364f404c393189ec70d7b8a9284349774e00118fb636dbfefa86eb57220a49a5a7324e9f0484879d69afb199bb1c8ae7f0b5e591e
EBUILD gentoo-syntax-20190609.ebuild 1267 BLAKE2B a78aa52041af1cce8f0fd9b751a8f1bfb18675195cb5fd63f9a9de4059574b81e6c054a3fdda37f069b1f5423645fcddf2d700f4bc40807b8f6a41a245c8f8fe SHA512 e90b92d6cedb72ba2e7867e230d26c5640d25fa2a15b07ef558d9c82ea352a5095ccc50b9adfcd9deb11a0982d74db1e193d12bb2f30a915d3e273ac28180f40
+EBUILD gentoo-syntax-20191127.ebuild 1280 BLAKE2B 7a4f3b5918d2b4d4e658d0e22132f87f8d34a2f53933e0e388950b391519718c0bb3cd4d0b4f775a08337e191a1a82d7e409fa750a9bc8da24d5491a986cc9ed SHA512 93c1410db28dcccfe0a4142ff95a0bec09bc1c810a3defdd2e7a8130f9743907900731a153931b1ed30aef5aab9f0acc8e16a13e6c919be94029853f6143511b
EBUILD gentoo-syntax-99999999.ebuild 1087 BLAKE2B 9b7c64f1ec0215aa53e39c0c4db8352c47b19ee89a894dc95ef4a867415337ff901befaadf2ce468804e4167410c1d034002ca476c90925096875b3dc27b8868 SHA512 5f0e991bcc491e807ea86d89c47dcc8d6879c35d0f42d191a4e2cd4d40f117022e70cfb92503184e638273daed9780363066d07667c138592be1e1b6f4435b99
MISC metadata.xml 585 BLAKE2B 7f904a47ab12627ae911fa96328c50af2cb16b785fa0b60cace8a586b17de344625b749b52ef6b89b4751aba74bc25339b3e6c9105ee47d15b5c6539b5d902ee SHA512 dfed3c4c2b3697b00896591dc4b23eb6433ce77b4aaaab05119ca0b11e355e321b2cf5f0ab5e0b2dd075abd1a266908e07b80846a11d50f17155d7ab35e6c742
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-20191127.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-20191127.ebuild
new file mode 100644
index 000000000000..9ab8c1f38389
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-20191127.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Gentoo and Portage syntax highlighting"
+HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
+SRC_URI="https://gitweb.gentoo.org/proj/gentoo-syntax.git/snapshot/${P}.tar.bz2"
+
+LICENSE="vim"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="ignore-glep31"
+
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ default
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ fi
+ fi
+}