summaryrefslogtreecommitdiff
path: root/app-vim/gentoo-syntax
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /app-vim/gentoo-syntax
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'app-vim/gentoo-syntax')
-rw-r--r--app-vim/gentoo-syntax/Manifest2
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-20211116.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/app-vim/gentoo-syntax/Manifest b/app-vim/gentoo-syntax/Manifest
index f9128cbb321d..61551072d046 100644
--- a/app-vim/gentoo-syntax/Manifest
+++ b/app-vim/gentoo-syntax/Manifest
@@ -1,4 +1,6 @@
DIST gentoo-syntax-20210911.tar.bz2 18865 BLAKE2B 14dfe4b1eaab39a7de11c9b2e00c6a39385cd81d5717522dbac1f9ff265047c9ded745c335cca88413f6ad622f2858d996bdb39c5f4b1b4796ef7740c48c5f68 SHA512 b7ac7aba50c086e1e550692426bb38dbca5bf4770c148ff4989686ef043a2d990710bec782f1baba582ff67da3b3db007a4dbc6dec16f69830312205f1a45d3c
+DIST gentoo-syntax-20211116.tar.bz2 18849 BLAKE2B 7d9ebe080d09dc604a0847285d1cda90d4d5538360bce122bba054b66e2be9afcd8fed7098664447e0f07adc1ae6c4feff08e48884995fbbe3abd925e5d7bf67 SHA512 ff13926998e6d5b530bdf7ab8a6427264980d194b13c16811cc6380b0aa4edc7445ffa157afe3c19b536bcd42208d85a36e92921b1c2c8c3e4c136295b00f770
EBUILD gentoo-syntax-20210911.ebuild 1237 BLAKE2B e4376fc40d3d7c829e253383c0744e4369d312657a539b5d82387128c50c2ae35431207171d9f9a312e7350485c7f2c417d07c665fa345b5193964489a1727f5 SHA512 e692cfa8d4e37e9bfa6bea96c7948e1230a6ebf7bdb7601980e3f918fdec8e69d7e7273e6979ea3ac36446c2c7040e79e09e42d185e8e915d00286cd6c693521
+EBUILD gentoo-syntax-20211116.ebuild 1245 BLAKE2B 4de7b82e15d0e8e0716fa3b419297d3ce15bbe12d7fc8007e231bc09cd3d9236af4c5d08e7c6dec0c1058150eec401c37a24d3b5bade0319947617db9d358bb6 SHA512 9a14cb1d43d22cde53c0f7c9598bfdbb2cd1f0417bc69b604823f595b6f1a59a95aeb47cd61a68707abe8412a2ca44d71a67a51c731d7e083b2f4cab299e6584
EBUILD gentoo-syntax-99999999.ebuild 1084 BLAKE2B cbe1d6aa8eca271a997dec67ba8ba3725e3c50d97ff2f1f18c169bd3ea84ed568390ffef00742d20748dec2ec9b98468a119fc10b62bd55cd05e0506227e58cd SHA512 e59ceccbaaeb0947a66c079380269acd431d9694a20b851c13d5772a610306db1ddb04e8d8173ad5b84723077dae034a60ac7d53ba448ae00e816fdc03dc9f61
MISC metadata.xml 586 BLAKE2B 9425e6a21617f806a0232c7f0ff75f148dc6855679236c9c2b88270db48161d3bffcb32066b372dc6af9cbac594f9d9dce6447d03fc675c151e75982f86ba598 SHA512 cb343dede228edd5c51dc2b2f6b8a1f09e4847365284218d5eb0c23c675f32fe4ab5025c6671f1dafbb63a87b83763a9caf97b04945329c32a1898123149d04b
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-20211116.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-20211116.ebuild
new file mode 100644
index 000000000000..72f25ef766b6
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-20211116.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Gentoo and Portage syntax highlighting"
+HOMEPAGE="https://github.com/gentoo/gentoo-syntax"
+SRC_URI="https://gitweb.gentoo.org/proj/gentoo-syntax.git/snapshot/${P}.tar.bz2"
+
+LICENSE="vim"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="ignore-glep31"
+
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ default
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ fi
+ fi
+}