summaryrefslogtreecommitdiff
path: root/app-vim/foldutil
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-15 04:49:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-15 04:49:10 +0100
commitefca79f216bfeffd55e7731fbf24126d093e1084 (patch)
treef19ba31d8686b3de4192db3e4c4dc9f3d9af54b5 /app-vim/foldutil
parentea7f3f690b55cdfa8b2d350b03c1dfc0c8357a51 (diff)
gentoo auto-resync : 15:09:2023 - 04:49:10
Diffstat (limited to 'app-vim/foldutil')
-rw-r--r--app-vim/foldutil/Manifest1
-rw-r--r--app-vim/foldutil/foldutil-3.0-r2.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/app-vim/foldutil/Manifest b/app-vim/foldutil/Manifest
index 3e95cb5a159d..1c311f8aaf12 100644
--- a/app-vim/foldutil/Manifest
+++ b/app-vim/foldutil/Manifest
@@ -1,3 +1,4 @@
DIST foldutil-3.0.tar.bz2 7323 BLAKE2B de59313da23a277a2eb3e971b3033202001cd1304058b5e096e33e7c28f95326169754c0e0062120099677e567c6bd79b265a69524c8b8fe55a9666ab6bde23f SHA512 a38561c4530333f5a56596b2fe19a2892f58b4fd35229536c054578b199e9b6b19c18d255aa1b078d51ac4f610d4ca49b205d1929e8be51299bee527058b3452
EBUILD foldutil-3.0-r1.ebuild 547 BLAKE2B de6fe80efb4800fd32d0d87037ee2a211fdc53a600951a9e06c0124a8514c4b6e44399d6d8002d44c81bcedba704188580f0bdae69b4e0365c7b1d93243a6867 SHA512 9989b62e275c9a288a29f9cad66174ccaa83a3210e5cb4f0f2faf0f307f336bec0a2ef8ba1598aae14bee36af17aaaed17775a6dcb0ad68de44014a4217d0881
+EBUILD foldutil-3.0-r2.ebuild 544 BLAKE2B 28d5d8404fc8a8758c2de216245c9dfd944cf3be34a48ace7e6c1f5ff6f7333d6cd7ab051fd109ffdd320c5eb3c0ba22440faaac293e3af30fc6b242318152e3 SHA512 778f26f90b22ba4db0c4f747a71c6648468c928eb215781bdf0f51311f1ac83942d526f5cc0921b2150b1c1b50c06fa10bacf7157b3fea953be0d67d22b7365c
MISC metadata.xml 250 BLAKE2B 159edb6cbbe3884fd7b328cba2125da0a51b5c0be964e60b708efe1bd040a41abdf16f8dbcfaecb9e6e1073528ac99195a08d7045d433414ec2ba1c94d582761 SHA512 6c29f24b33b8829463103cee99e2cf65cf550aa1d6c60c5a746ca2947a97a052969c8dfb9d12ae8114db0971626f9246cb9e4808d951eeae78321325da1ac32a
diff --git a/app-vim/foldutil/foldutil-3.0-r2.ebuild b/app-vim/foldutil/foldutil-3.0-r2.ebuild
new file mode 100644
index 000000000000..24e498bbfa3e
--- /dev/null
+++ b/app-vim/foldutil/foldutil-3.0-r2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: fold creation utility"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=158"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+
+RDEPEND=">=app-vim/genutils-2.0"
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides a number of commands for working with folds:
+\ :FoldNonMatching [pattern] [context]
+\ :FoldShowLines {lines} [context]
+\ :FoldEndFolding"