summaryrefslogtreecommitdiff
path: root/app-vim/eruby-syntax
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-15 04:49:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-15 04:49:10 +0100
commitefca79f216bfeffd55e7731fbf24126d093e1084 (patch)
treef19ba31d8686b3de4192db3e4c4dc9f3d9af54b5 /app-vim/eruby-syntax
parentea7f3f690b55cdfa8b2d350b03c1dfc0c8357a51 (diff)
gentoo auto-resync : 15:09:2023 - 04:49:10
Diffstat (limited to 'app-vim/eruby-syntax')
-rw-r--r--app-vim/eruby-syntax/Manifest1
-rw-r--r--app-vim/eruby-syntax/eruby-syntax-2.0-r3.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/app-vim/eruby-syntax/Manifest b/app-vim/eruby-syntax/Manifest
index bae8db95aa0b..346cc01c9907 100644
--- a/app-vim/eruby-syntax/Manifest
+++ b/app-vim/eruby-syntax/Manifest
@@ -1,3 +1,4 @@
DIST eruby-syntax-2.0.tar.bz2 958 BLAKE2B 467e1df5bf32ad83bb427bfde6755425a752051b1532397e75f627dc084cfb6bbeba99655366698f812bd398b171fec4110af0fba28de1900a0a22aaa08b01ec SHA512 1fdf1e6ad95109528b13b30d7504da2ea8678785b1a716c33bae0b94fafb8f23d50d81022b5bc373c1970f6d3df04f2e78d87fbb2067f0c270780963b472468c
EBUILD eruby-syntax-2.0-r2.ebuild 508 BLAKE2B 667ccf36a52872f96ab636fc74785abec5928756fba543ffb2a03c8034f75e8543bcd023cc7c8bcfdd2a101ce0f8282ac244b1d4b46a2a10752d20a2044df023 SHA512 7bc24fa9a4c78276e23a6ae6ee15574b826252f034a3a6d83d1a26e4fddb17cbcc0219511bfc44903d8b7544e8dfbd4f12a749ebd9ef143350c6860d787c6c1d
+EBUILD eruby-syntax-2.0-r3.ebuild 514 BLAKE2B 8d037c09fdd51aac9c2b4a27e1c9e18a900f0ef1400f905bb3ccf14a0c25a7f6e028dbb7e3066ee671e5f090aca2b78aff4e0ae98936d04030e74e22dace4739 SHA512 0b49ee5c9b968c1deeab3758b3c53531c4ec9ea6d7b6464635a0d3678da1df4279501687e337d6dd2e6622fba9f6fc229dbb929f9c82e067e595d61705c2eead
MISC metadata.xml 250 BLAKE2B 159edb6cbbe3884fd7b328cba2125da0a51b5c0be964e60b708efe1bd040a41abdf16f8dbcfaecb9e6e1073528ac99195a08d7045d433414ec2ba1c94d582761 SHA512 6c29f24b33b8829463103cee99e2cf65cf550aa1d6c60c5a746ca2947a97a052969c8dfb9d12ae8114db0971626f9246cb9e4808d951eeae78321325da1ac32a
diff --git a/app-vim/eruby-syntax/eruby-syntax-2.0-r3.ebuild b/app-vim/eruby-syntax/eruby-syntax-2.0-r3.ebuild
new file mode 100644
index 000000000000..2bf72a0fb743
--- /dev/null
+++ b/app-vim/eruby-syntax/eruby-syntax-2.0-r3.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: syntax highlighting for eruby"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=403"
+
+LICENSE="vim.org"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+VIM_PLUGIN_HELPTEXT="This plugin provides syntax highlighting for eruby"
+
+src_prepare() {
+ default
+ sed -i -e 's#hi link#hi def link#' syntax/eruby.vim || die "sed failed"
+}