summaryrefslogtreecommitdiff
path: root/app-vim/easytags/easytags-3.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
commite23cdda4dbb0c83b9e682ab5e916085a35203da5 (patch)
tree5a4ac448a3b288b731c24d947e0ce52df3cab07b /app-vim/easytags/easytags-3.11.ebuild
parent8187a741807f3e9a9e26304973cf18087dcf2560 (diff)
gentoo resync : 23.06.2018
Diffstat (limited to 'app-vim/easytags/easytags-3.11.ebuild')
-rw-r--r--app-vim/easytags/easytags-3.11.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/app-vim/easytags/easytags-3.11.ebuild b/app-vim/easytags/easytags-3.11.ebuild
index e7ddf382b0fb..79b37e481e5a 100644
--- a/app-vim/easytags/easytags-3.11.ebuild
+++ b/app-vim/easytags/easytags-3.11.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -14,15 +14,21 @@ LICENSE="MIT"
KEYWORDS="amd64 x86"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RDEPEND="${PYTHON_DEPS}
+RDEPEND="
+ ${PYTHON_DEPS}
>=app-vim/vim-misc-1.17.6
dev-util/ctags"
VIM_PLUGIN_HELPFILES="${PN}.txt"
-S=${WORKDIR}/vim-${P}
+S="${WORKDIR}/vim-${P}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-ctags-detection.patch"
+)
src_prepare() {
+ epatch "${PATCHES[@]}"
# remove unnecessary files
rm addon-info.json INSTALL.md README.md || die
}