summaryrefslogtreecommitdiff
path: root/app-vim/easytags/easytags-3.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:56:41 +0100
commitd87262dd706fec50cd150aab3e93883b6337466d (patch)
tree246b44c33ad7a57550430b0a60fa0df86a3c9e68 /app-vim/easytags/easytags-3.11.ebuild
parent71bc00c87bba1ce31de0dac6c3b7fd1aee6917fc (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/easytags/easytags-3.11.ebuild')
-rw-r--r--app-vim/easytags/easytags-3.11.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/app-vim/easytags/easytags-3.11.ebuild b/app-vim/easytags/easytags-3.11.ebuild
deleted file mode 100644
index 79b37e481e5a..000000000000
--- a/app-vim/easytags/easytags-3.11.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit python-single-r1 vim-plugin
-
-DESCRIPTION="vim plugin: automated tag file generation and syntax highlighting"
-HOMEPAGE="http://peterodding.com/code/vim/easytags/"
-SRC_URI="https://github.com/xolox/vim-${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="MIT"
-KEYWORDS="amd64 x86"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- ${PYTHON_DEPS}
- >=app-vim/vim-misc-1.17.6
- dev-util/ctags"
-
-VIM_PLUGIN_HELPFILES="${PN}.txt"
-
-S="${WORKDIR}/vim-${P}"
-
-PATCHES=(
- "${FILESDIR}/${P}-fix-ctags-detection.patch"
-)
-
-src_prepare() {
- epatch "${PATCHES[@]}"
- # remove unnecessary files
- rm addon-info.json INSTALL.md README.md || die
-}
-
-src_install() {
- vim-plugin_src_install
-
- # fix scripts
- fperms 755 /usr/share/vim/vimfiles/misc/easytags/{normalize-tags,why-so-slow}.py
- python_fix_shebang "${ED}"/usr/share/vim/vimfiles/misc/easytags/{normalize-tags,why-so-slow}.py
-}