summaryrefslogtreecommitdiff
path: root/app-vim/easytags/easytags-3.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-vim/easytags/easytags-3.11.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-vim/easytags/easytags-3.11.ebuild')
-rw-r--r--app-vim/easytags/easytags-3.11.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-vim/easytags/easytags-3.11.ebuild b/app-vim/easytags/easytags-3.11.ebuild
new file mode 100644
index 000000000000..79b37e481e5a
--- /dev/null
+++ b/app-vim/easytags/easytags-3.11.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 vim-plugin
+
+DESCRIPTION="vim plugin: automated tag file generation and syntax highlighting"
+HOMEPAGE="http://peterodding.com/code/vim/easytags/"
+SRC_URI="https://github.com/xolox/vim-${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+KEYWORDS="amd64 x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=app-vim/vim-misc-1.17.6
+ dev-util/ctags"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+S="${WORKDIR}/vim-${P}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix-ctags-detection.patch"
+)
+
+src_prepare() {
+ epatch "${PATCHES[@]}"
+ # remove unnecessary files
+ rm addon-info.json INSTALL.md README.md || die
+}
+
+src_install() {
+ vim-plugin_src_install
+
+ # fix scripts
+ fperms 755 /usr/share/vim/vimfiles/misc/easytags/{normalize-tags,why-so-slow}.py
+ python_fix_shebang "${ED}"/usr/share/vim/vimfiles/misc/easytags/{normalize-tags,why-so-slow}.py
+}